No devices show for CEO's device in Teams

Silver Contributor

I have our CEO who relies on Teams several times a day, devices menu on Windows doesn't show camera or microphone or speaker. It does work on Microsoft Edge but not app. I've tried checking for updates. I've uninstalled and reinstalled. I cleared the cache folder and all files and folders in %appdata%\Microsot\Teams. I've rebooted the device. I've signed the user out and back in several times and still doesn't work. He is having to reply on his cellphone. which is hard to deal with as the CEO. Any other ideas??? 

9 Replies
Sounds like something is hijacking those peripherals. Any other crappy Video conferencing software on there like Zoom, Blue Jeans, or SnapCamera lol.

Uninstall Teams and clear out all the crap indicated in this post

I have the same problem. It started today after Microsoft Teams upgraded to version (64-bit).
If I reinstall it from the installer for version then it works. As soon as Teams updates to latest version (I click "Check for updates" to force the update) all devices in Teams settings are gone (no calls possible at all).
I don't think that this is a hijacking problem. It is related to Teams version.Screenshot 2022-02-08 224209.png

Go figure, a Teams update broke it. At least you have those Fluent Emoticons though! Those are way more important now since you can't call anyone!

That is the version he has and it is the same as the image. We had a couple users last week and a simple uninstall re-install worked but not this user and since he was traveling couldn't get to it til today. Microsoft is recommended removing the profile and re-adding it. If I could find a previous version mentioned i'd try that first.
Most of those steps I have tried except to remove entries from the registry.
I do believe it is the aboved mentioned version of Teams that broke it.

@Vladimir_Tchalkov I found the previous version and downloaded it and installed it on his computer and it works so as long as it doesn't auto-update until the next version Microsoft releases, hopefully he'll be fine.

I have an assumption what might be causing the issue, although I don't know how to solve it (teams updates automatically so I don't think installing old version is a permanent solution).
Our users have display name that includes company name with brackets (i.e. Vladimir Tchalkov (Crossroad)).
When I open the Device tab of Teams the following error shows in error logs and dev console:

0.2-angular-jquery.min-eee9041.js:114 Error: SyntaxError: Invalid regular expression: /C:\\Users\\VladimirTchalkov(Cro/: Unterminated group
    at v (<anonymous>:17:181254)
    at Object.get (<anonymous>:17:182711)
    at e.getSlimCoreVersion ...

This error does not appear in logs with the older version of teams.

It looks like my the path to my profile folder (that includes my display name with the brackets) is being used as a part of a regular expression and the bracket in the display name is causing the problem. Changing display name or recreating profile with different path is not feasible for us.

@Jeffrey Allen , can you check if your profile paths have similar symbols (i.e. brackets)?

I don't know if Microsoft is monitoring this forum. Might be a better idea to submit a support incident about this issue.


There is one additional workaround that helps me with this issue - making calls in the web based teams - 

@Vladimir_Tchalkov, yes our CEO does have what we call a title account and his name at the end is in () and so your issue might be related. I asked the support person to pass along the fact that the current version is buggy. No issue with this until the current version and I hope his Teams won't auto update until maybe a fix but I told him no guarantee.