New Temas can not show all organizations that i am in

Copper Contributor

Recantly MS forces to migrate to the new teams desktop. I switched to it. I must work with two organizations. In clasic teams desktop, i could have see and switch between organiations. But in NEW Teams it is not possible. And only one organizations is showen. I don't know how it decides to show which organization.


It is impossible to use New Teams. On the other hand, Teams Web can show both of my organizations. And i can switch between them. Teams Web is working but New Teams desktop is NOT working.

I tried to delete all cache, uninstall all teams instances etc... i spent lots of time.

I am spending extra time to overcome Teams problems. I am not sure why you released it with such bugs.





7 Replies

@sedat_etyuboglu It sounds like it's an issue with the installation of Teams on your computer.  I have the new Teams on multiple computers and multiple tenants and can switch between tenants that I'm a guest on. A lot of the clean up scripts for clearing the cache out there are geard towards the Classic Teams or the Teams Machine Wide installer.  Check your installed apps to make sure you're cleaning up the New Teams installation.

In your Installed app list in Settings you should see a version of Teams called one called "Microsoft Teams (work or school)".  Hit the ... and choose Advanced Options.  Try resetting and/or repairing from there.  Hopfully that will fix the issue.

@systems_mavenThank you. As you suggested i did reset & repair. None of them helped. I also checked the account page to see my organizations. And i can see that i have three oganizations.


If its running for you, this shows that New Teams is not steable. I think MS should seriously think to switch-back to clasic teams. It is working for me without touching anything. And as i said web is also working. I just installed New Teams, nothing else. I did NOT do anything other than allowing to use New Teams.


There is one another strange thing, when New Teams strats it shows one of the organizations that i am guest. It does not show my home organization. How it decides to show that organization. It is very strange.


It seems it reads some old cache or setting from somewhere on my computer. I deleted teams cache folder as described here It did not help. I completely uninstalled clasic teams, new teams. And re installed just new teams. Nothing changed.


Is there any one from MS to explain what is happining?




@sedat_etyuboglu that's super frustrating.  I'd suggest opening up a ticket with Microsoft to see if they have a fix.  If it helps, here's the version running on my computer if they need an example of a working version for troubleshooting.





Have you tried to use the new Teams client on another PC? I have partially found this issue and I think is becasue of performance/chache problems in the new Teams client
I just test it with my other computer which is Windows 10. And it is same.
On that computer i was using clasic teams. After you sugested, i started teams and it asked to me to switch to new teams and i accepted. After new teams starts my home organization was lost in the organizations list. After i switched to the clasic teams back. And my home organization and other ones restored in the organizations list. New Teams is problamatic. Or MS has to inform us what seeting can cause this.

I'm using my personal account here, as I am not allowed to use my organization's for this kind of actions.

I had this problem on a company I work with (roughly 200 employees) who had this problem. After extensive trial and error I managed to find a way to make all organizations appear proerly on Teams - and apparently it might have to do with the current early access content (I may be wrong on that). This is what I did, in this order:

1) Closed all instances of Teams (both classic and new) and uninstall both via control panel and/or Apps&Features;

2) Deleted folder %AppData%\Microsoft\Teams. This will remove stored content related to the current user's Teams account (Classic).

3) Deleted folder %LocalAppData%\Microsoft\Teams. This will remove local Teams (classic) user's information on Windows (I believe).

4) Deleted Folder %LocalAppData%\Packages\MSTeams_8wekyb3d8bbwe. This will remove all information regarding your user on Teams (new). They are usually migrated from the previous folders when you upgrade from Teams classic to the new Teams;

5) Disconnected the user's Work/School account through Access Work or School;

6) Deleted Folders %LocalAppData%\Microsoft\OneAuth, %LocalAppData%\Microsoft\TokenBroker and %LocalAppData%\Microsoft\IdentityCache. This removes, as far as I know, all user Login information and Tokens, and might include credentials to other services. I am not certain this step is relevant, but it seemed to do the job on my end (it was safe for me to do so as this organization's employees are not supposed to store any kind of passwords) - do so at own risk!

7) Reinstalled Teams (I used the latest exe for the classic teams and upgraded to the new one, but it seems to work on the teamsbootstrapper.exe with argument "-p" for the new one as well - I could not verify through the .msix as this organization's Laptops have the microsoft Store disabled).

This also seemed to remove the Early Access versions across all clients I tested this procedure with (which aren't many, admittedly).
Also note that I am in no way any Microsoft MVP, so do not take it as a fix or a solution for all. This worked on my scenarios and hasn't been tested properly on other environments. Take it with a grain of salt.

Best Regards,
Seth Dakam