New Teams - unable to open a new Excel file created in Teams. Invalid file format

Copper Contributor

For some (but not all) of our users on New Teams, if they create an Excel file in a Team Files section using the New->Excel menu option, the file fails to open stating is has the wrong file type or is corrupt.  Editing the file via Teams or the web works, and once you've done that it opens in desktop Excel, but as we use desktop apps for everything, especially Excel, this is a very laborious workaround every time someone creates a new file.

 

Anyone else seen this?  So far MS support suggest opening in Teams instead of Excel, which doesn't work for us as our spreadsheets are Excel addins don't work there.

5 Replies

Hello @Rob Butterworth 

welcome to the Microsoft community, my name is Recep I'll be happy to help you today.

I understand that you are unable to open an excel file created in New Teams and this is happening to some specific users.

 

please try the below solutions to repair your file.

Solution 1: Change the default file format.

Try changing the Excel default file format by following these steps:

In Excel 2010 and newer versions, click on the File menu.
Then, in the Info screen that appears, click on Options.
In the 'Excel Options' window, under the Save workbooks section, click on the Save files in this file format: drop-down. Next, select a file format (i.e., the one supported by your Excel version).
Click OK.
Check if you can open your Excel file. If not, try the next solution.

Solution 2: Edit the excel file permissions.

Follow these steps to change the file permissions and see if it fixes the problem:

Right-click on the file that will not open and click Properties.
In the file properties dialog box, click the Security tab and hit the Edit button.
When the file's permissions dialog box appears, click on the Add button.
Next, click on the advanced button from the 'Select Users or Groups' window.
Select Find Now. A list of all users and groups will be displayed in a search results box. Choose everyone's group from the list and hit OK.
You can see the 'Everyone' group in the 'Enter the object names to select' textbox. Click OK once again to return to the file's permission dialog box.
Click everyone from the Group or usernames: box and check all the checkboxes under Allow.
Click on Apply and then OK.

 

If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)

 

Thanks, but sadly none of this is relevant. Excel is fine, it works fine with local and file server files, it works fine with Teams Classic. This issue only occurs when opening a file that was just created INSIDE the Teams client with the New... button. Opening that new file in the web or teams edit view, then opening in Excel works, but opening in Excel immediately does not. There are no file type issues here, it's a New Teams issue.

Hello@Rob Butterworth 

 

Thank you very much for your response, then try to clear Teams app caches and revert with the behavior.

 

Windows:

------------------------

Close Outlook and other apps that have integrated features with Teams, go to File Explorer and type %appdata%\Microsoft\teams. Then delete the following files. You can move the files to another place to avoid the data loss:

 

·         In Application Cache -> Cache folder, delete all files in it.

·         In Blob_storage folder, delete all files.

·         In Cache folder, delete all files.

·         In databases folder, delete all files.

·         In GPUCache folder, delete all files.

·         In IndexedDB folder, delete the .db file.

·         In Local Storage folder, delete all files.

·         In tmp folder, delete all files.

·         Delete the file “settings".

If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)

 

Thanks, doesn't help.

I have just has a response from MS support that this is a known bug in the new Teams, which will be fixed at some point, and the workaround until then is to initially open the file in Teams or on the web, close it, then reopen it in Excel and it will work. Hardly slick, but ok.
It did work for some files, but not for all of them. Something that worked for me was to sync the files with the file explorer, all files would open from there.

Will be using it until Microsoft fixes this bug.