Microsoft Tech Community Live:  Microsoft Teams Edition
November 09, 2021, 08:00 AM - 12:00 PM (PST)

New bug? Presence issue when switching to different orgs

Regular Contributor

The latest update to Teams desktop client (64-bit) seems to have broken presence indication for us. We noticed that it's happening when switching among orgs that you're a guest in.


What I've noticed is that if you launch Teams, you default to the last Org you were set to - and for that, presence works correctly, but if you switch to a different org, presence is no longer shown. It only seems to be available for the initial org you land in when launching the app.

I've submitted a bug report, but has anyone else noticed this? I've done the usual troubleshooting, including clearing the local Teams cache.


1. Launch Teams - land into last open org - Presence looks ok:
Screenshot 2020-11-13 081902.png

2. Switch to a different Org (several orgs available to switch to, doesn't matter which one):
Screenshot 2020-11-13 081535.png


3. Presence info not available

Screenshot 2020-11-13 081942.png




4 Replies

Hey Bob,

I had the problem recently and clearing the cache from this particular doc resolved it

Some clear cache docs are different but this seems the most thorough one and works for me 99% of the time. If you have done all this then would advise opening a ticket. I have raised the bug here and informed the product team, so you may want to update your ticket to avoid them asking you to do it


Hope it gets resolved! Hope it will soon

Best, Chris

@Christopher Hoard Hey Chris thanks, yes I had actually already done the usual cache clearing exercises, uninstalled/reinstalled, tried on a few machines/different accounts. Also had submitted a bug report to Teams UserVoice prior to posting here. We'll see.


(Also, FWIW, if I back-rev to the previous client version, it works. Once I update to the latest, it doesn't.)

best response confirmed by Bob Manjoney (Regular Contributor)
No worries Bob, that's now raised internally with the product team referencing this thread and the associated uservoice. Let's hope this is remediated in the next few days or so

Best, Chris

@Christopher Hoard I have nearly the same problem with Teams for Mac after it was updated to The W10 version is working and also in the previous Mac version it worked.

I try to change between teams in different organisations with the same 365 account as login.

Earlier I could just switch, no I have to abort Teams after giving my login information. When I restart I'm in the new team.