My webcam freezes on other participants end

Copper Contributor

Hello everyone,


This one has been bugging me for a while and I original put it down to using the preview builds of Windows. But I now have clean installed with the Windows 21H1 as of 22/05/2021 and the issue was there from the very first attempt at using Teams.


When I start/join a meeting in the desktop app, and we all have our webcams on, I can see everyone else's feed. And I can see my own feed. My feed is clear and the video is continuous on my side. However, my feed freezes every few seconds on everyone else's end resulting in less than ideal visuals on their end.


If I swap to using the browser version, my video comes through perfectly clear.


My data connection is not constrained with a consistent 50mbps+ download and 15mbps+ upload. I am using ethernet from the PC to the NBN router:




Attached are two videos that are recorded to Streams. One from the desktop application, and the other from the browser.


The following is what I have tried to do to troubleshoot (roughly in this order):

  • Different USB ports
  • Different web cams (my main webcam is a Logitech Streamcam)
  • Different desktop applications (V-Cam, Logitech Capture)
  • Connect to wireless network
  • Disabled QOS in the Teams admin portal
  • Disabled QOS on my router,
  • Registry hack to enable webcam work around


I have not seen this issue in any other video conferencing systems (Zoom, WebEx etc.)


Any ideas on where else to look would be greatly appreciated.

13 Replies



What's your CPU/GPU utilisation during a call?


Also might be worth testing your network for packetloss, try running an assessment using Download Skype for Business Network Assessment Tool from Official Microsoft Download Center

Hey @Steven Collier 


CPU and GPU are at a nominal usage level, with CPU at approx. 5% to 10% during the teams meeting



I haven't seen the GPU go above 50% and it is nominally at 10% utilization during the call (4K monitor, usually have GPU bound programs in the background).


After running the Network Assessment Tool:


PowerShell 7.1.3
Copyright (c) Microsoft Corporation.
Type 'help' to get help.

PS C:\Program Files (x86)\Microsoft Skype for Business Network Assessment Tool> .\NetworkAssessmentTool.exe
Skype for Business - Network Assessment Tool

Initializing audio call.

Starting new call
Iteration 1 / 1

Audio call started. Waiting for call to end...
Call should end shortly after configured duration of 17 s.

Call completed.
Packet loss rate:     0.00117785630153121
RTT latency:          20 ms
Packets sent:         849
Packets received:     848
Average jitter:       5.61292 ms
Packet reorder ratio: 0


Or from the report: 

CallStartTime	PacketLossRate	RoundTripLatencyInMs	PacketsSent	PacketsReceived	AverageJitterInMs	PacketReorderRatio
24/05/2021 08:38:18	0.00117785630153121	20	849	848	5.61292	0




Nothing wrong with either of those, clearly there is nothing in particular that is constrained.


It would be useful to look at the Call Records that your admin will be able to do through Teams Admin Centre, dig through the details. It's a puzzling one TBH, as your preview is working perfectly it's unlikely to be the camera or USB bus, network looks fine during that test (might be worth repeating). Also clearly audio packets are getting though just fine.


I'm slightly interested by your comments about disabling QoS, is there something on your network that might be changing traffic between you are the internet?

Hey @Steven Collier


I am the admin for our tenant. What report in particular should I pull down?


I also did a few other things to my physical network to eliminate anything by having my machine directly connected to the router. The QoS is the only thing that may have impacted the network packets (hence disabling as a test). The other part, is being an electron app, I would have thought that the web version would use the same protocol to transmit the video stream.


In the morning I will try a few tests with the logging for meeting diagnostics enabled and post the results from there.

I will also try and bypass the router tomorrow as well.

@SkywalkerIsNull I would find yourself under Users ... Meetings and Calls then identify a call where you had the stuttering. Look at the advanced tab and see the network stats for your outgoing video.


QoS would seem suspicious as it would appear to only be effecting video traffic, the only differences really between audio and video are destination port and QoS tags.  

Morning @Steven Collier


I re-routed the cables slightly this morning and my PC's NIC was directly attached to the NTD (NBN Network Termination Device aka. Internet port) so in effect there was no routers, or switches between the PC and the internet connection. After doing this, and testing, the video was transmitted fine, I then added back in the router, tested again, it was also fine, then added back in the main switch next to the router, also fine, then I added back in my switch in my office, also fine.


Strange as none of the networking equipment was rebooted, just the Cat6 was unplugged, and plugged into a different port. I have a few meetings on it today and will ask the participants if it is fine on their end.


Looking at the reports for the video I recorded over the weekend, it is showing 100% packet loss.... That doesn't seem right, the audio was coming through. I will have to spend more time looking through the reports, and docs to understand what they are telling me.

Out of curiosity, what Internet provider are you using? I'm experiencing the same issue where it seems I can recieve video and screen shares fine, audio incoming and outgoing is fine (although apparently audio improved when I seitched off my camera), but I cannot share my video or screen with others without it being extrememly laggy.

The issue for me hit when I moved to NBN. I've tried multiple routers and it works fine if I hotspot to my phone.

I've read that Optus and Telstra have the issue but switching to other providers resolves it. I'm slightly sceptical but am considering making the switch.

Hey @mark63355 annoyingly enough, it started again 2 days ago after we had a blackout.


I am with Telstra for both my NBN connection, and my mobile. In your digging, or what you have seen/read/heard, is there any specific reason that Telstra or Optus are having this issue but the others are not? Or maybe it is an NBN specific issue?



Joining the team with the same problem: Web based version of MS Teams works just fine. Installed app has no issues with calls but screen sharing is terribly luggish. Interesting if I am using my company laptop of the same network if has no issues, so I am not really sure it is related to ISP (I am on Telstra HFC btw).


And I don't really understand why web-based version is not affected.

Ok. Just another update. Seems like Telstra still. Connected to phone hotspot and problem gone. Connected directly to Coax-to Ethernet bridge (so no router/switch) and problem is back. Intresting I feel like that problem has started after I stopped paying for speed boost.
I ended up switching provider yesterday (Aussie BroadBand) and no longer had the problem. I've been on a few video/screen share calls today with no issue. In speaking with others in my company I've heard that two people on Telstra NBN were not experiencing the issue. One was Sattelite and the other didn't know what type of NBN she was on. FYI I'm FTTC and was Telstra Cable before that (two weeks ago) and had no issue. I do have a colleague who uses Tangerine as their ISP and they have the same issue.

My guess is that Microsoft and the ISP's know the issue and the fix but Microsoft don't want to make the change at their end and the ISP's don't want to make it at there's because it in some way compromises their systems. It seems to be too common an issue and too easy to reproduce and pin down for them not to know. But I can also respect that there's a fair chance that the key information is not making its way from the end user support channels to the developers at Microsoft and the ISP's. I've asked my IT to raise the issue with Telstra as they have more clout than me.


I switched last night to Aussie Broadband (and they did the switch within about 20mintues of me completing the online application) and all my meetings this morning have had my web cam come through on the other participants end, and my screen sharing have been perfect. Plus it is now cheaper, faster, and the static IP is included in the bundle.

similir this end. My webcam keeps freezing during a teams call. Ok with zoom. I was wired to my router at 100 full duplex. When we went wireless it worked. No idea why wireless fixed the issue. @SkywalkerIsNull