SOLVED

My voice is not audible when I'm typing on keyboard

New Contributor

Hi Guys,

 

When I'm in a call with others I'm perfectly audible until I start typing on my keyboard. They don't hear the keyboard "clicking", and they neither hear me speaking. It is like I'm being muted... but I'm not.

I'm sure that this is some Teams feature since, when I'm testing the same things in sound recorder (windows 11) I can perfectly hear myself speaking even if I'm typing on my keyboard. I tried lot of Teams audio device settings, but nothing changed (as per /testcall-s). 

(Tried with two usb headsets (Logitech Pro X, SteelSeries Artic 5) 

4 Replies
Hello,

So it that the issue when you start typing they cannot hear your voice at all or do the external people don't hear your keyboard typing. As the key board typing or any background noise will automatically cancelled via noise cancellation.

Additionally while you start typing on the keyboard if the other participants are unable to hear you seems like the drivers compatibility issue between Keyboard and Mouse. Can you check if all the drivers are updated?

With Regards,
Satish Upadhyaya

Hi @Satish2805,

 

Thanks for your answer! 

So in short, as soon as I start typing nothing is audible from my side, neither my voice, neither the keyboard, nothing.

Noise suppression is turned off in Teams, and if I'm testing my audio while typing via Sound Recorder or Teams Web version, everything is working fine as expected. 

I'm using a notebook, and it is not important at all if I'm typing on my built in keyboard, wireless, or wired one.)

 

My drivers are up to date, and again, I'm only experiencing this with Teams desktop. 

 

 

 

Hi Borondy,

Seems like the devices drivers needs to be upgrade. Can you check and confirm if the issue also happens with other UCC platforms like WebEx, Zoom or others as well?

With Regards,
Satish Upadhyaya
best response confirmed by borondy (New Contributor)
Solution

Hi@Satish2805 

 

As mentioned I did not experienced anything like this with other apps. 

However I had the time to investigate the issue a bit more extensively. It seems that when I'm setting the Noise suppression to High everything works as expected. 

 

It is a bit counterintuitive to me, I'd think if I set NS to off, there would be no magic happening behind the scenes, which can cause issues like this.

 

Anyways if anyone else is facing this:

Setting Noise suppression to High solved for me :) (Off or Low was problematic here)