MS Teams Desktop APP - Sorry we couldn't connect you.

Copper Contributor

Hello all ,


I want to roll out MS teams to use company wide since we have included in our office365 bundle . I have created a small user test group before company wide push. My issue is that in some of the users i am facing the issue where the desktop app will not connect to any Audio/Video meeting with the error "Sorry we couldn't connect you". Others it works fine.


Clipboard - March 27, 2020 2_01 PM.png


The users can join all meeting fine via a browser though.


I have checked event logs and the only error i see when joining a meeting is the 4227 error TCIP .


Clipboard - March 30, 2020 9_30 AM.png


I have tried reinstall ms teams , restart pc , check drivers nothing.


I havealso tried manual install from downlaoded msi and exe still same issue.


Can anyone pelase help ?

26 Replies

@Kleanthis I had the same issue on saturday. Sometimes I got connected, and then disconnected a few minutes later.

Did a reboot, and made sure to close Discord and Slack before re-joining the meeting. Worked fine for 6 hours after that. Not sure what fixed it.

No thats not it my users never managed to connect via the app since installation.

try to connect throw mobile app to be sure there is no issue related to licences for this user 

Do you have a proxy setup for internet traffic? Can users open meetings in the webclient? If you log into the Teams client off of your corporate network, can you join a Teams meeting?

I have seen this over the last week. Particularly mid Teams meeting. 


I see Event ID 4227 then a DNS client event error (1014) about unable to resolve a DNS entry for the Teams infrastructure.

This started happening about a week ago and has increased in severity.

@Kleanthis We have the same error message since one month and still have not any solutions. Someone have success ??

We have been having this same issue with multiple users were I work. This is what correct the issue for us.  Create a .reg file with this info, run Regedit as Admin and import. Perform a reboot and test.


Hope this helps!



Windows Registry Editor Version 5.00







@spidermn one of our users is having this issue. I have tried disabling Windows Defender firewall and that did not help. she can call form the app on a different device, from the web version of Teams, and from her cellphone. 

Did you try the reg edit? It has worked in every instance where we have had the issue.

@spidermn I do not have the folder AutoEnrollment


I have had success with the instructions in this article for increasing the TCP/IP port count and increasing timeout values.


It's also worth checking the network path between Teams clients in the Teams servers. Look for security software and transparent proxies that block or impede traffic.

FWIW I was able to resolve this for me by Sign Out and back in again. A password change may have affected it. Note that restarting the app was not enough.

@Kleanthis Was this fixed? i have the same issue with multiple users and seems to me is a issue with out cisco anyconnect seure vpn client. Once i stop the wensecurity it works. but wanted to check if there is any better option u found.


I have tried all the options below but no luck.



Hello, I have the same problem on my PC, can't connect to a call, but on my mobile I can connect.  the issue is of Microsoft teams for PC.   Microsoft looks like a government agency, as they don't care about this kind of issue. 

@Andrew Matthews 


I made a bit of progress on fixing this with a combination of the following.


1) Change the IPv4 / IPv6 preference to use IPv4 first

2) Increase the size of the TCPIP IPv4 socket pool to the maximum size

3) Update devices to Windows 10 2004.


The number of incidents that were being reported by the user base has dropped dramatically. We still get the odd incident on poor network connections (home broadband) but at one point we were getting hundreds of reports a week of this issue occurring.

@Kleanthis I can tell you that I tried all of the above, but it doesn't work with the Windows Firewall Client if you are running ISA 2004, 2006, or Microsoft Forefront Threat Management Gateway. (Well I have only tested the 2004 ISA Firewall Client.)

@Kleanthis I have been having this issue non-stop on Windows 7 for a month now. This software worked great for 2 weeks before I started getting this error. The error started showing up every once in a while, and now I cannot call or receive calls from anyone. My current work around is to send a screen share first, then add in audio and disconnect screen share.

@Kleanthis Any luck on this?