Moodle Tab in Teams Requires Sign In

New Contributor

We've pretty much successfully integrated Moodle with Teams (Team creation upon Moodle course creation, user enrollment sync, etc...) with the exception of one piece.  The Moodle Tab, created in each Team, requires the user sign in again to O365.  It was my understanding that the integration would handle the authentication via OpenID Connect and the "enable authenticated users to create web tokens" setting.  I realize the Moodle tab is just an iFrame essentially, but am I mistaken that this is not how the integration works?  Will our users just have to sign in again to access Moodle content in that tab?

5 Replies

Hi @KyleGrizzell ,


Just double checking, was it this setup that you followed?





Yup, that’s the one.



We have been setting this up recently and I have been through the documentation many times and have the same thing.

Moodle is able to create the Teams from the chosen course and add the Moodle tab but then we are presented with the following:


We have to login to Office 365 and then it'll ask us to login to our Moodle before it presents the course content correctly.  Once we have logged in we can go to other Teams which have the Moodle tab during the same Teams session and not have to log in again but the next time we use Teams we will to go through the same login process.  This happens for Teams Web app or Teams Desktop.

I'd really appreciate any suggests to sort this out as we want to go live with this asap.



Check this thread out over at GitHub.


Looks like that's just how it works and there's no workaround.  I've noticed the integration works best via web browser versus the standalone desktop app though.  Chrome or Edge would be the best option, since it has the most functionality with regard to video chat (if that's needed).

I also got this error. I tried   new install moodle and  setting up integration countless time but no luck. 


In Teams Desktop app , tab is just empty. 

In Web App it fetches course list for 1 or 2 seconds but then redirects to dialog manual login  or Login to office365. Logging in again doesnt work.


During  teams web tab add phase, i run developor tools and generated following   errors : 


2021-01-22T12:19:16.476Z AUTHMSAL: Event: adal:tokenRenewFailure, code: invalid_resource|AADSTS500011: The resource principal named api:// was not found in the tenant named xxxxxxxxx-xxxxxx-xxxxx-xxxx-xxxxxxxxxxx. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You might have sent your authentication request to the wrong tenant.
Trace ID: 2e944688-a460-40bf-b95a-d62d8bda1400
Correlation ID: 98c4e1b6-b248-4101-afa0-3cefc70e009c
Timestamp: 2021-01-22 12:19:15Z, resource: api://, action: resourceDisabled


any suggestions ?