Missing messages in shared channels in Windows client

Contributor

Hi,

 

We've begun using the new "Shared Channels" extensively inside our org. However we've noticed a major bug which makes it impossible to use this new feature before it has been fixed:

 

When we create a shared channel and share it with another team, then the members of each team only sees some messages and it's completely random who sees what. The messages are simply not showing up for some users while they do for others. This is only a problem with the Windows client. It works fine in the web version and on mobile (IOS).

 

We're running Microsoft Teams version 1.5.00.21668 64-bit. We also tried upgrading a few user to latest preview build but this did not fix the issue.

 

Example:

I am member of team A. I create a shared channel and shares it with the owner of team B. The owner accepts the invite and i accept the placement of the channel at team B. All is good. The channel shows up both in my team A and in team B.

 

However, if I write a new thread, sometimes it'll show for all members of team B and sometimes only for some members. It will always make the channel name bold as if there is a new unread message but if the user clicks on the channel then there is nothing new. If they look in the mobile app or the web version they can see the message.

 

If they then write a response on their phone, it'll sometimes show up on the Windows version but as a new thread and not a response.

 

This makes the new shared channels unreliable as one can't guarantee that other members actually gets your message.

10 Replies

@kaaremai this sounds like something to raise as a support request 

@kaaremai In your admin portal, under Support .. New Service Request

We have the exact same issue here... @kaaremai, any response yet from MS Support?

@Philip Haglund 

 

Yes I got a response asking me to clear the Teams cache through these steps:

 

Spoiler

Clear Teams cache in Windows

  1. If Teams and outlook app is still running, right-click the Teams icon in the taskbar, and then select Quit and close outlook app as well. 
  2. Open the Run dialog box by pressing the Windows logo key 
     

     

     +R.
  3. In the Run dialog box, enter %appdata%\Microsoft\Teams, and then select OK.
  4. Delete all files and folders in the %appdata%\Microsoft\Teams directory.
  5. Restart Teams.

Clear Teams cache in macOS

  1. If Teams and outlook app is still running, right-click the Teams icon in the dock, and then select Quit, or press Command (⌘)-Q and close outlook app. 

  2. In the Finder, open the /Applications/Utilities folder, and then double-click Terminal.

  3. Enter the following command, and then press Return:

    ConsoleCopy
     
    rm -r ~/Library/Application\ Support/Microsoft/Teams
  4. Restart Teams.

This does indeed fix the problem for PAST missing messages. We're currently investigating/observing if it also fixes the problem for future messages (messages being sent after the cache clearing).

I can now confirm that it does not fix the issue. Shared channels are unreliable in the windows client! Everything is OK in both the browser version and the ios mobile version.
Same issue here - number of us realised we are missing messages in the shared channels.
Noticed there was a difference between the Browser, Client and Mobile, tried clearing the cache, full reboot etc and it only got as far as making the Browser and Client the same - which is still missing messages compared to the Mobile.
Seems very random on which messages are visible in a thread. The initial threads never seem to be missing, just replies?
We will raise a support request with Microsoft but has anyone managed to fix it temporarily even?

@Nicki_GreeneNo permanent fix. Only clearing the cache will solve the issue temporary. Right now I'm not in the mood to contact the most useless MS Support (Teams). So many issues and escalations from past cases...

I have a similar issue with a Shared Channel here where people can see the files in "Files" but suddenly they cannot see Posts anymore.
I have raised a support call - will update with any significant news