Microsoft Teams webcam over RDP no longer working

Copper Contributor



I am using RDP to connect to a Windows 10 VM running on Hyper-V, on which I use Microsoft Teams. I have enabled the sharing of the webcam to that VM and everything has been perfectly working since 9 months.


Since a week from now this setup stopped to work, with Microsoft Teams showing an error message stating that Video is not working and displaying a black screen in place of the webcam image. The webcam light keeps off, so I imagine that Teams is unable to open it for some reason.

After checking all that I can, including the fact that the webcam is perfectly working over RDP on the same VM with all the other applications (Zoom, the Windows camera app, etc.) including Teams itself when running within a browser, I reinstalled the plain OS in the VM just to check that it worked again a couple of times and then stopped with the same issue.


I am using the latest version of Windows 10 both on host and guest, Teams version is (64 bit). I tried also downgrading Teams to a previous version without luck.


At this point I am stuck using Teams in a web browser and I really do not understand what could be preventing the webcam to work in the standalone app. Any help will be appreciated.

14 Replies

@gxcare ditto here too. Around 10 employees all lost webcam to Teams. did same as you camera works everywhere but Teams desktop app. the built in mic on the camera works. a solution or acknowledgement that teams has a problem would be good.

@gxcare   Also in the same boat and worked on this for hours.  Created this last night:


WVD - Teams Camera stopped redirecting - Microsoft Tech Community 


I feel like I"ve done everything under the sun to figure this out on my own as well as recommendations from other techs out there.  I'm shocked there are not more people involved with this issue as I have a hard time believing it's only a couple people having issues.  I hope Microsoft does something about this issue soon because it's becoming more and more of a problem.


I also have a support ticket open right now (opened on Friday) and have a dozen questions and screenshots to get for them for tomorrow.  I will report back anything useful that may come of it.



Got it working.  here is what fixed it for us:


Add this registry key to the session Host:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\AddIns\WebRTC Redirector]
"WebRTC Redirector Enabled"=dword:00000001


Uninstall "Teams Machine-Wide Installer"  from the Control Panel


Download Teams from this link:


Install with these parameters:

msiexec /i "Teams_windows_x64.msi" /l*v teams.log ALLUSER=1 ALLUSERS=1


Then start Teams and test.  For some reason I had to start and stop teams twice before it worked. 


Let me know if that helped!



I'm guessing you're running in Media Optimization mode then with this fix?   I've been up and running with Media Optimization mode "connected" but I don't like the drawbacks that come with it.  Although, in the end, I guess you do have video but it torqued off a lot of people losing virtual backgrounds.



Turned out the next day the Session Host that were working stopped working and the process above would not resolve again.  I have had several workign sessions with MS Teams Support and they have no clue at this point.  I am suppose to "update the drivers on the the host today????"  I will appease to just keep the process rolling.

Bump. MS, come on. It is ONLY Teams that exhibits this issue, so it's clearly not a remote desktop or USB camera issue since I can immediately do vid conf with ANY other service. How are we supposed to rely on Teams if it isn't working?

@gxcare  We are still having this issue. Is it already solved for you? Please mark as unsolved if possible.

@basmicaYes, the problem is still there exactly as at the beginning. It is funny that they marked as solution something that the poster already clarified that wasn't really working.

In general, if you start from scratch (reinstall everything) it works for some time then suddenly it stops.

@NateRA  I did figure out a temporary solution that oddly works across profiles. It is a camera permissions issue in Teams. It may take a few tries to get the permissions corrected but it does work. Disable camera in Teams, quit teams. Open teams enable camera, quit teams. opens teams check camera in devices if no picture repeat process. sometimes it takes 3 times others 6 times of enabling and disabling camera permission.

Tried this but the camera enabled for half a second then went gray again @NateRA 

@gxcare Have you found a solution yet? Still struggling with a Server 2019 RDS...

No solution. This is a shame. Doesn't work on Windows Server 2016 either @saschaki 

@ccpit based on this Microsoft article I assume Teams is not meant to be used for video calls on RDS. Use Teams with remote desktop services - Microsoft Teams | Microsoft Docs

It says "Currently, Teams in a remote desktop services environment is available with support for collaboration and chat functionality. To ensure an optimal user experience, follow the guidance in this article." 

So no call support for RDS environments (yet)? Shame.