Microsoft Teams switching between organizations

Occasional Visitor


I'm using Microsoft Teams from Mac and I have an issue.

I'm in an organization on Teams and some days ago I was invited in another organization. Now when I try to join to this new organization switching the account, I have a message on the application that said "We're switching you to your other account. It'll just take a moment...", then the application crashes and comes back to the page with "You have been invited to <organization name>".

Some times instead appears also the message "We ran into a problem. Reconnecting..."

I have aready tried to disintall the application and I have also tried to do this with the iPhone app and also with a computer with Microsoft, but the result is always the same.


I have no idea how to fix it, 

thanks a lot for everyone that can help me.


3 Replies

Hi @clascordi  try to join another company invite via web browser on MAC once done you will get the drop down next to your name on right side top corner to switch between teams organisations. Once this is done try to use Teams Client on MAC.

I think is worth to try the workaround suggested by the way, Teams is having different issues over the last few days due to the heavy use of the service

I have a similar issue.  My organization changes (we were bought) so I have two teams accounts (old company and new company). When I try to open files in the new company account, Teams only wants to open it in the old account - it switches me when I click on the application (in this case it's stream) and then of course the file doesn't exist since it's in a different teams account. No idea how to fix this. I've tried everything.  @clascordi