Microsoft Teams Room MTR - you'll need a new app to open this skype-mrx

This thread has been locked for new comments by a moderator, if you have a new similar issue then please start a new thread.
Occasional Contributor

Intel NUC with Logitech TAP

Error you'll need a new app to open this skype-mrx


The popup is blocking the MTR from signing in, its currently happening on 2 devices, will troubleshoot and update, unless someone has any hints/tips






26 Replies
I would go into the admin side and check that your Windows build and MTR app version are compliant as a first step. If it has taken a recent Windows update you may be able to roll it back depending on how long ago it was taken.

If your app is out of date with your windows version I would update to the latest build manually:

If you are still seeing issues you may need to completely restore the unit:



Did you ever find a fix for this? We are seeing this on a new Logitech Tap room install after doing a manual update.



I'm afraid not, the only fix was to reset the unit following the recovery tool guide


Use the Microsoft Teams Rooms recovery tool - Microsoft Teams | Microsoft Docs

Doh. Okay, we followed the steps for the recovery tool and afterwards we still weren't able to log in AND the Microsoft Store / AppInstaller apps are missing. So we are engaged with Logitech support to correct.

Thanks for the update!

@cjohnston Did Logitech ever get this sorted out for you? I have the same issue on a few of my units.

Same issue here (Microsoft Store and Teams Room App won't run) with a Logitech Tap w/Intel NUC bundle. Opened a ticket with Logitech. They referred me to Microsoft. Microsoft has been looking at the log files that I uploaded for the last 5 days and has only offered 'try updating your firmware' (based on what I don't know) as a solution so far. We're eager to get this solved.
The easiest way to get up and running again is to re-image the NUC. Ask Logitech for the image, they should be able to provide you with a base build image for the Intel NUC. Then you will just need to leave it to sit for a day or so to take all its updates and you should be good to go.

@justinbliss I'll give it a go.  Logitech's first impulse was to create an RMA to swap out the unit. This didn't seem right since we're presumably dealing with a software vs. hardware issue.  What little help they do have online points to running standard OS and device updates and if all else fails using the MTR Recovery Tool.  We'll see if my request for a Logitech specific recovery image gets us anywhere tomorrow.


I was able to go into System Restore and restore the NUC back to a point a few days ago and was able to get back up and running without having to re-image.
How do I get to the point where I can interact with the NUC?
We have a black screen with cursor and nothing else
Hello, we now have the same issue in 8 meetingrooms. Is there an update or something at short term that you know off?

Same issue with 5 Poly Lenovo MTR computes surfaced this week for us.  Case opened with MSFT and escalated to product group.  Nothing back from MSFT so far.

We applied the MTRemediate PowerShell script from Microsoft and let the box restart a few times then the problem was resolved.

Same problem here. It is really taking a lot of time to fix this issue. Where did You contact Logitech? @Shervan_Torabi 

best response confirmed by Therese_Solimeno (Moderator)
There was a poster named RGaray would posted a solution that fixed the problem for me but it looks like his post was removed. The solution he recommended which worked for me was to:

1. Log in as Admin, open the MS store app and run all of the updates for all apps.
2. Elevate the Skype user to the Administrator group
3. Log in as Skype
4. The skype-mrx error will occur. Press CTRL ALT DEL and open Task Manager (you can since Skype is now Admin). You NEED to wait for the Teams Room autorun thing to "timeout" give it a few minutes. When the screen goes black you will see the task manager.
5. Run a new task - shell:AppsFolder
6. Run the Teams Room app.
7. It appears to set itself as default for skype-mrx. Reboot and test.
8. Remove Skype from the Administrators group.



Thanks for saving and reposting. No idea why my initial post got removed. Even the replies of some folks saying that it worked were also removed....


Additionally, you need to have the out-of-band (KB5015020) patch installed that corrects the error which was caused by the original May 2022 Cumulative Update. 


May 19, 2022—KB5015020 (OS Builds 19042.1708) Out-of-band (


I presume that as people stumble across this issue post-June updates that the June 2022 Cumulative will contain the corrected fix as well.