Microsoft Teams - problems deleting a free organisation

Occasional Visitor

Hi, I hope someone can help - I've been pointed to put up a post here by Microsoft Support after chatting with them for half an hour.


Problem: I can't seem to delete my free Microsoft organisation - I have error messages, and no access to an admin email address. I also can't access another organisation on the Microsoft Teams App.



I was asked by my organisation (will call it OrgA for now) to join Microsoft Teams, using my personal email address (Gmail) so I could be a guest presenter. I went through the sign up procedure without a problem, and when viewing my organisations on my account (on Microsoft online), I could see OrgA's name. However, when I went to sign into the Microsoft Teams App, it did not list OrgA anywhere. Instead it said "You're not on Teams yet, but you can set it up for your organisation".


After many attempts of signing in and out and re-downloading the Microsoft Teams App from a specific web address from OrgA, I am afraid I probably complicated matters, and clicked "Sign up for Teams" on the Microsoft Teams App, and signed up for free for a Microsoft account using my same Gmail. In the process, I set it up with a new organisation name (called OrgB for this example). OrgB I could see and access on the Microsoft Teams App, but still no OrgA. Both OrgA and OrgB come up when I sign into Microsoft online. 


Since then I have tried to delete OrgB on Microsoft online, but every time I click 'Leave organisation', it says "Unexpected error occurred. Please try again. If this issue persists, please contact support". This has happened several times, and the person on the chat told me "Do not retry again and again".


I tried to follow the advice on this helpful thread (, but despite being the only admin of OrgB (as I set it up and can see on the Microsoft Teams App that I have admin access and there are no other members to the organisation), I cannot see an admin email address listed anywhere on Microsoft online. So I am unable to go through the above link's process to delete OrgB.


Of course, this also doesn't solve the problem of why I can't access OrgA on the Microsoft Teams App. I don't know if this is because I am using a Gmail account (as I have seen on other threads that people in the past (Nov 2019) have had issues accessing the Microsoft Teams App with a Gmail account.


Any help and direction is appreciated. I am sorry if this is posted in the wrong section - my patience has worn thin and I'm sure my stupidity is showing!

2 Replies
I have the same problem.

@hbates10 - You should be able to manage and delete via the Azure portal at . You need to be sure you log in with the email address/password the free Teams set up has been created against. 


There's some useful detail in this post too if the above doesn't help: Delete Teams account - Microsoft Tech Community


There's also: How to delete Microsoft Teams account (