Microsoft Teams integration with Zapier or've%20tried%20to%20disconnect%20and%20reconnect%20several%20times%20with%20no%20success.%20The%20strange%20thing%20though%20is%20that%20I%20do%20see%20a%20consent%20has%20been%20given%20to%20Zapier%20on%20Microsoft's%20admin%20screen.%20Since%20Zapier's%20support%20is%20not%20getting%20back%20to%20me%2C%20I%20was%20wondering%20there's%20anyone%20else%20who''t%20even%20connect%20to%20my%20account%2C%20I%20get%20a%20Microsoft%20error%20message%20saying%20my%20email%20is%20not%20recognised%2C%20even%20though%20I'm%20able%20to%20login%20on%20a%20new%20tab.%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E--%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20on%20a%20Free%20Teams%20account%20and%20am%20currently%20the%20Admin%20of%20that%20account%2C%20just%20so%20you%20know.%20I've%20also%20tried%20different%20browsers%20on%20incognito%20mode.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20what%20might%20be%20the%20problem%3F%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1119780%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHow-to%3C%2FLINGO-LABEL%3E%''
Occasional Visitor

Hi there,


I was wondering if anyone here has been able to connect their Teams account to Zapier or


  • When Zapier asks me to grant them permission I get the following error from Zapier: DataPostError: Problem creating Connected Account Test. (authentication failed: Something went wrong with the authentication process. Please reconnect your account and try again.)

I've tried to disconnect and reconnect several times with no success. The strange thing though is that I do see a consent has been given to Zapier on Microsoft's admin screen. Since Zapier's support is not getting back to me, I was wondering there's anyone else who's been through the same problem?


  • With I can't even connect to my account, I get a Microsoft error message saying my email is not recognised, even though I'm able to login on a new tab.




I'm on a Free Teams account and am currently the Admin of that account, just so you know. I've also tried different browsers on incognito mode.


Any ideas what might be the problem?

Thanks in advance!


3 Replies

I'm having this same issue with


I also have a free Teams account. I have no other subscription to other Microsoft products with my email address.


I'm able to login with my email to most Microsoft sites: Teams,, etc.

Is M Teams not allow to connect to Zapier on the Free plan?

@eduardographeec  Did you find a solution for this?