Microsoft Teams Crashing When Starting or Answering a Video Call

Highlighted
Deleted
Not applicable

Hi,

 

As the problem listed above states, Teams crashes with a white screen then recovers and states that there was a glitch. I've checked for updates and even checked for any potential driver issues that may be interfering with it, but with no luck. I've seen other people with the same problem, but no solution as of yet. Any ideas? 

 

Thanks! 

25 Replies
Highlighted
Highlighted
Yup that's what I'm seeing when someone shares content. Same can crash my app when remote party starts sharing content as well.
Highlighted

Got the same problem with the exact same webcam model: Logitech c930e (worked for over 6 months and then the crashes started - so might also be related to some kinde of Windows update).

Highlighted

I am also having some crashes of teams occuring in conjunction with a Logitech C920 in the following scenarios:

 

  • Clicking the camera off button
  • Locking up video in a one on one call as opposed to a multi-person call
Highlighted

I am having the same issue. Our company is in the early phases of adopting Office 365 and Microsoft Teams. We are also heavy users Surface Book PCs. My issue is with a Surface Book with the Nvidia video card. If I answer a call with Video it will crash. If I answer a call with audio but then enable video it will crash. 

 

Log entry:

Fri Aug 10 2018 14:57:22 GMT-0400 (Eastern Daylight Time) <13392> -- event -- name: desktop_renderer_process_crashed, url: https://, type: renderer, appRuntime: 23806.547, appInitialized: true, activities: single_people_profile,batch_people_profile,calling_intent,call_accept,admin_update_consumptionhorizon_clientonly,chat-page-title-update,presence_in_sync,hid_device_stop_ringing_from_app,ext_app_launchApp_undefined,single_people_profile,batch_people_profile,batch_people_profile,admin_update_consumptionhorizon,unified_presence_publish_endpoint_presence,unified_presence_implicitswitch_mystatus,media_connected,screen_sharing_control_data_channel_state,video_stream_rendering,video_stream_rendering_performance,hid_device_off_hook_from_app,hid_device_resume_from_app,hid_device_stop_ringing_from_app,hid_device_unmute_from_app,hid_device_off_hook_on_device,unified_presence_get_presence,presence_ischanged_mystatus,batch_people_profile,unified_presence_get_presence,blur_get_effects_capability,presence_post_active,unified_presence_post_active, timeSinceActivity: 12.733, appStates: Started,SSOStart,SSOSuccess,SSOSuccess,Initialized,CheckingUpdates,CheckingUpdates,CheckingUpdates,InCall, timeSinceAppState: 18.129000186920166, webAppStates: Inactive,LongInactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,Inactive,Interactive,InCall, timeSinceWebAppState: 18.134000062942505, diagnosticEvents: ua:batch_people_profile,ua:hid_device_start_ringing_from_app,ua:single_people_profile,ua:single_people_profile,ua:batch_people_profile,ua:calling_intent,ua:call_accept,ua:admin_update_consumptionhorizon_clientonly,ua:chat-page-title-update,ua:presence_in_sync,ua:hid_device_stop_ringing_from_app,ua:ext_app_launchApp_undefined,ua:single_people_profile,ua:batch_people_profile,ua:batch_people_profile,ua:admin_update_consumptionhorizon,ua:unified_presence_publish_endpoint_presence,ua:unified_presence_implicitswitch_mystatus,ua:media_connected,ua:screen_sharing_control_data_channel_state,ua:video_stream_rendering,ua:video_stream_rendering_performance,ua:hid_device_off_hook_from_app,ua:hid_device_resume_from_app,ua:hid_device_stop_ringing_from_app,ua:hid_device_unmute_from_app,ua:hid_device_off_hook_on_device,ua:unified_presence_get_presence,ua:presence_ischanged_mystatus,ua:batch_people_profile,ua:unified_presence_get_presence,ua:blur_get_effects_capability,ua:presence_post_active,ua:unified_presence_post_active, timeSinceLastDiagnosticEvent: 12.733000040054321, timeSinceSecondLastDiagnosticEvent: 12.733000040054321,
Fri Aug 10 2018 14:57:22 GMT-0400 (Eastern Daylight Time) <13392> -- error -- Renderer process crashed with url https://, restarting the app.

Highlighted

@Tony Ball 

I had the exact same problem where Teams would go into a loop where it crashed every time it started, then restarted, then crashed...

 

The log file also indicated a problem with the rederering. So, after a week of looking for a solution on this post and others, I thougt it might just help if the window was minimized during the startup process. And it helped! I minimized the window as fast as possible, when Teams started, waited 10-15 seconds to let it load completely, and voilá.. I could maximize the window again and start using Teams normally.

 

Maybe this trick will work for others too? (I haven't had to use it again)