Microsoft Teams and Outlook Lose Connection and Ask for Password

%3CLINGO-SUB%20id%3D%22lingo-sub-2629858%22%20slang%3D%22en-US%22%3EMicrosoft%20Teams%20and%20Outlook%20Lose%20Connection%20and%20Ask%20for%20Password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2629858%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20we%20have%20several%20users%20(eight)%20who%20have%20all%20caught%20the%20same%20Microsoft%20Outlook%20and%20Teams%20bug.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20an%20Office%20365%20shop%20and%20use%20the%20desktop%20versions%20of%20both%20Outlook%20and%20Teams.%20A%20few%20months%20ago%20users%20noticed%20that%20Outlook%20and%20Teams%20would%20break%20around%20the%20same%20time.%20Outlook%20would%20say%20%22Need%20Password%22%20along%20the%20bottom%20and%20Teams%20would%20have%20the%20banner%20%22We%20ran%20into%20a%20problem.%20Reconnecting%20...%20Refresh%20Now%22.%20When%20you%20click%20need%20password%20and%20put%20in%20your%20password%20nothing%20happens.%20Same%20goes%20for%20the%20%22Refresh%20Now%22%20in%20Teams.%20We%20did%20find%20that%20a%20reboot%20of%20the%20machine%20will%20fix%20the%20issue%2C%20Outlook%20and%20Teams%20will%20log%20in%20perfectly%2C%20for%20about%20a%20day%20and%20then%20it%20will%20break%20again.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20is%20interesting%20is%20that%20just%20a%20few%20weeks%20ago%20we%20found%20that%20if%20we%20created%20the%20following%20registry%20keys%20it%20fixed%20Outlook%20from%20breaking%20and%20asking%20for%20a%20password.%20The%20problem%20is%20that%20Teams%20still%20breaks.%20I%20am%20pretty%20sure%20they%20are%20related%20issues%20since%20they%20happen%20on%20the%20same%20machines%20and%20break%20at%20close%20to%20the%20same%20times.%3C%2FP%3E%3CUL%3E%3CLI%3EHKEY_CURRENT_USER%5CSoftware%5CMicrosoft%5COffice%5C16.0%5CCommon%5CIdentity%2C%20create%20a%20DWORD%20value%20named%20EnableADAL%20and%20set%20it%20to%20zero.%3C%2FLI%3E%3C%2FUL%3E%3CUL%3E%3CLI%3E%5BHKEY_CURRENT_USER%5CSoftware%5CMicrosoft%5COffice%5C16.0%5CCommon%5CIdentity%26nbsp%3B%22DisableADALatopWAMOverride%22%3Ddword%3A00000001%3C%2FLI%3E%3CLI%3E%5BHKEY_CURRENT_USER%5CSoftware%5CMicrosoft%5COffice%5C16.0%5CCommon%5CIdentity%26nbsp%3B%22DisableAADWAM%22%3Ddword%3A00000001%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESteps%20Already%20Taken%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EClearing%20out%20the%20Credential%20Manger%3C%2FP%3E%3CP%3EReinstalling%20MS%20Office%3C%2FP%3E%3CP%3ECompletely%20deleting%20and%20recreating%20the%20Windows%20Profile%3C%2FP%3E%3CP%3ERunning%20%22sfc%20%2Fscannow%22%3C%2FP%3E%3CP%3EDeleted%20the%20profile%20in%20Outlook%20and%20recreated%20it%3C%2FP%3E%3CP%3EThe%20registry%20keys%20listed%20above%20that%20fixed%20the%20issue%20for%20Outlook%3C%2FP%3E%3CP%3ERemoving%20and%20readding%20the%20work%20account%20under%20Settings%26gt%3BAccounts%20in%20Windows.%3C%2FP%3E%3CP%3EHad%20the%20same%20user%20use%20their%20current%20laptop%20and%20a%20different%20laptop%20simultaneously.%20Teams%20broke%20on%20the%20current%20laptop%20but%20not%20the%20new%20one.%3C%2FP%3E%3CP%3EI%20also%20did%20all%20the%20steps%20that%20I%20could%20see%20in%20the%20following%20articles%20including%20running%20the%20scripts%20and%20the%20scrubbers.%3C%2FP%3E%3CP%3EOLicenseCleanup%3C%2FP%3E%3CP%3Esignoutofwamaccount%3C%2FP%3E%3CP%3EWPJCleanUp%3C%2FP%3E%3CP%3E(Ran%20a%20scrubber%20to%20check%20for%20login%20issues)%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foutlook%2Ftroubleshoot%2Fauthentication%2Fcontinually-prompts-password-office-365%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foutlook%2Ftroubleshoot%2Fauthentication%2Fcontinually-prompts-password-office-365%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Ftroubleshoot%2Fadministration%2Fdisabling-adal-wam-not-recommended%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Ftroubleshoot%2Fadministration%2Fdisabling-adal-wam-not-recommended%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice%2Ftroubleshoot%2Factivation%2Freset-office-365-proplus-activation-state%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice%2Ftroubleshoot%2Factivation%2Freset-office-365-proplus-activation-state%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Ftroubleshoot%2Fauthentication%2Fautomatic-authentication-fails%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Ftroubleshoot%2Fauthentication%2Fautomatic-authentication-fails%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20is%20greatly%20appreciated!%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2629858%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2630777%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20and%20Outlook%20Lose%20Connection%20and%20Ask%20for%20Password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2630777%22%20slang%3D%22en-US%22%3EHi%2C%20this%20is%20difficult%20to%20troubleshoot%20remote%20without%20knowing%20anything%20else%20about%20your%20environment.%20But%20I%20would%20remove%20those%20registry%20keys%20and%20%22start%20over%22.%20You%20simply%20shouldn't%20disable%20these.%20Perhaps%20you%20should%20open%20a%20proper%20support%20ticket%20instead%20too.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2634043%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20and%20Outlook%20Lose%20Connection%20and%20Ask%20for%20Password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2634043%22%20slang%3D%22en-US%22%3E%3CP%3EMaybe%20you%20can%20help%20explain%20what%20those%20keys%20do%20then%3F%20Why%20does%20disabling%20them%20fix%20the%20problem%3F%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi we have several users (eight) who have all caught the same Microsoft Outlook and Teams bug.

 

We are an Office 365 shop and use the desktop versions of both Outlook and Teams. A few months ago users noticed that Outlook and Teams would break around the same time. Outlook would say "Need Password" along the bottom and Teams would have the banner "We ran into a problem. Reconnecting ... Refresh Now". When you click need password and put in your password nothing happens. Same goes for the "Refresh Now" in Teams. We did find that a reboot of the machine will fix the issue, Outlook and Teams will log in perfectly, for about a day and then it will break again. 

 

What is interesting is that just a few weeks ago we found that if we created the following registry keys it fixed Outlook from breaking and asking for a password. The problem is that Teams still breaks. I am pretty sure they are related issues since they happen on the same machines and break at close to the same times.

  • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, create a DWORD value named EnableADAL and set it to zero.
  • [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity "DisableADALatopWAMOverride"=dword:00000001
  • [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity "DisableAADWAM"=dword:00000001

 

Steps Already Taken

Clearing out the Credential Manger

Reinstalling MS Office

Completely deleting and recreating the Windows Profile

Running "sfc /scannow"

Deleted the profile in Outlook and recreated it

Uninstall and reinstall Teams

The registry keys listed above that fixed the issue for Outlook

Removing and readding the work account under Settings>Accounts in Windows.

Had the same user use their current laptop and a different laptop simultaneously. Teams broke on the current laptop but not the new one.

Even completely wiped one user's computer and reinstalled Windows and the issue came back.

I also did all the steps that I could see in the following articles including running the scripts and the scrubbers.

OLicenseCleanup

signoutofwamaccount

WPJCleanUp

(Ran a scrubber to check for login issues)

https://docs.microsoft.com/en-us/outlook/troubleshoot/authentication/continually-prompts-password-of...

https://docs.microsoft.com/en-us/office365/troubleshoot/administration/disabling-adal-wam-not-recomm...

https://docs.microsoft.com/en-us/office/troubleshoot/activation/reset-office-365-proplus-activation-...

https://docs.microsoft.com/en-us/office365/troubleshoot/authentication/automatic-authentication-fail...

 

 

Any help is greatly appreciated!

Thanks!

3 Replies
Hi, this is difficult to troubleshoot remote without knowing anything else about your environment. But I would remove those registry keys and "start over". You simply shouldn't disable these. Perhaps you should open a proper support ticket instead too.

Maybe you can help explain what those keys do then? Why does disabling them fix the problem? Thanks!

@haydenjohnson As I mentioned you'd be better off with a proper support ticket with Microsoft.

 

"Disabling ADAL or WAM authentication as a solution to fix sign-in or activation issues can have adverse effects in your environment and is not recommended."

 

These reg keys where common like 2018/2019, not needed now with updated OS and applications.

 

But I suppose here's what happens, not being an expert on the process.

 

EnableADAL 0 = you disable modern authentication (ADAL/OAuth)
DisableADALatopWAMOverride 1 = you disable WAM (Web account manager) and revert to ADAL for Outlook
DisableAADWAM 1 = you disable the Azure AD WAM process

 

WAM is the default token broker for W10 and is also associated with SSO/authentication.

 

You should instead use this if any. AlwaysUseMSOAuthForAutoDiscover 1 = force modern authentication