Microsoft Team for Mac app stuck on error screen on startup

New Contributor

I accidently logged into Microsoft Team for Mac app using my personal Office 365 account.  I get this error now.


ms.teams.error copy.jpg


I tried uninstalling the app AND removing all Microsoft Teams app preferences.  Restarted. I reinstalled the app. I even logged out of Office 365 in my other apps. 


Everytime I load up Microsoft Teams for Mac I still get the same error screen. Doen't even prompt me to login.


D'oh! Something went wrong...
Error code - 500
Any solutions would be appreciated.
12 Replies

I'm having similar issues with the Windows desktop app, it seems like they have some token related problems. After the token expires in few days time, it starts working just fine...

best response confirmed by ThereseSolimeno (Microsoft)

1- start the Microsoft mac client Teams


(Obviously it locks to the point that we know ...) but !!!


2- press the dock icon with the right mouse button. It opens a small context menu ...
"Disconnect" with the voice.


3- disconnect by clicking on the application after a few moments closes.


4- restarting the application this time the credential window opens.


5- At this point you enter the credentials of 365 office ... and ... everything works great !!!

Thanks, this worked for me!

Thanks don Diego, your solution also worked for me!

Great! Only needed step 2 and knew what to do. Thanks!
Saved my day. Thanks!

On Mac OSX Mojave:  when I right click, I don't see "Disconnect," only "Sign out."  Clicking sign out has no effect.  Still stuck with:


Error code - 500

Tried the sign out and login method with no improvement. Also did a restart. Other microsoft office 365 programs work as intended, only teams server is down. 


Same everything works except Teams. I can sign-in Teams on my phone and web browser, but not on the Mac App

@BQuick I had the same issue, found if I signed out and waited for the app to recycle (rather than a forced quit) it worked OK.  In my case this was I think because I have changed companies and my old credentials were embedded and causing the lock out 

Currently running on a 2019 MBP - OS X Mojave 10.14.1 and had this issue.  All I was able to do was launch the app and while it was in the error mode, right clicked on the icon in the dock and clicked "Sign Out" this then prompted the original O365 Credentials screen.  Logged back in and everything is working.  One thing to note, i think the plist file for the original credentials is what causes this loop.  Based on what i can see since I had changed my AD password, the original which was in there wasn't signing in properly.  By signing out with this method it flushes the plist file i think and then allows for new auth kext to be configured. Just my thoughts. 




Tried all the above suggestions.  Signing-out didn't work.  It would reload with the same error.  What worked for me, I removed the (1)Teams application, (2)deleted the folder library/microsoft/teams and (3)reinstall Teams.  It then came up and asked for MS credentials.  System was a MBA that was originally running Mojava, it was upgraded to Big Sur with the same error.