Message policy will not update for user

New Contributor

I have set a new policy for myself only to test the message deletion policy, I have set the "Owners can delete sent messages" in the new messages policy, applied the policy to myself by searching for my user account clicking on my name and changing the drop down from the global policy to the new policy and save the changes.

Annotation 2019-03-21 155811.jpg
No matter how many times I change and save this it keeps the setting.

Now my issue is that I never get the option as an owner to enable owners being able to delete messages for the teams I own, so digging around in the new admin portal I noticed that if I search the users section for my user account, click the check mark beside my name and click edit at the top, I get a side menu that pops out, in this side menu it defaults to the global policy and no matter how many times I change and save it, it reverts back to the global policy.

Annotation 2019-03-21 160117.jpg

I have reset my original change that saves to the global and tried to change and save it through the side menu pop out and no matter what I do the side menu will not update, and I can not delete posts, on new or old teams.

5 Replies
Hi @USWM_Jeff

Frustrating issue.

What browser were you using? Have you tried on any other browsers?

How about trying the change through Powershell too?

Hope that helps with your issue

Best, Chris

Thank you for the reply @Christopher Hoard 

I have made the change in IE, Edge and Chrome, same thing happens.


I requested our Azure admin run the PS script to see if this will resolve the issue, he confirmed he ran it successfully, I signed back in and it's the same issue. He suggested that it could take time for the setting to change, so essentially it's a waiting game to see if the fix worked after waiting some time.

Great, let me know how it goes!

Best, Chris

@USWM_Jeff I did see that some of the policy changes takes at least 24 hours to reflect. And as you stated even though you make a change, when you go back to the screen you will see the previous value set. Wait for 24 hours and check


@Maruthi Gadde 

It is indeed the waiting period, I tested it with another user yesterday to confirm, the weird thing is that the side menu still shows all the global policies, but what matters for me is that the delete option finally started working, and confirmed that it started working after waiting a day for the other user as well.

Thank you for all your help!