Member Posts in Private Channel fail to send

New Contributor

We've got a private channel within a team where we want members to be able to create new posts. However, whenever a member tries to make a post, it returns "Failed to send", whether from the web client or the desktop application. Owners can post fine.


The odd thing is, within the same team, we have another private channel where members can create new posts just fine.


I took a peek into the web requests made from the web client, and this is the returned details:

"subCode": "AclCheckFailed",
"details": "Member role User does not have the desired capability NewPost, it is disabled by capability override.",
"errorCode": null,
"errorSubCode": null


This appears to be a simple permission issue, but for the life of me I cannot figure out where I could grant such a thing. It seems simple to do in a Standard (public) channel, but I don't know where to go in our private channel.


Any help is appreciated, thanks.

8 Replies
Yeah the settings for standard channels are different. Can you try removing one of the members of the private channel, then re-add them and see if this makes a difference?
We also encountered the same issue since 14th of May. Out of a number of private channels, there is a single private channel that keeps giving a Failed to send error when a member posts something. I've tested creating a private channel on the same Teams team and it lets me send the message.
No fix, I'm afraid. I also tried creating a new, test private channel, and members can't post in that either.
If there is no common factor here and this is random, then my suggestion would be to open a support ticket with Microsoft.

One other question, does the team with the problem have a sensitivity labels applied to it?
best response confirmed by PeterRising (MVP)
Turns out it wasn't that, however, that did help lead me in the right direction: our General channel within the team had "Only owners can post messages" (which is a setting we want for General). I flipped it back to "Anyone can post messages" to see if that would affect my private channels, but unfortunately it didn't. I still couldn't post.

However, I left the General channel set to "Anyone can post messages", and I created another new private test channel, and this time it worked. I was able to create new posts, as a member, within my private channel just fine. I tested with a guest account too, and that also worked. I then flipped the General channel back to "Only owners can post messages", and I was still able to post messages in my test private channel.

So, it seems like, upon creation of the channel, the General channel's setting is mirrored into the new private channel, only there appears to be no obvious way to tweak it within the private channel after it's been created.

I'll open a ticket with Microsoft to assist with our already-active channels, but at least I have this workaround for new channels. Thanks for leading me in the right direction!
Ah that's interesting and a good quirk to watch out for. Thanks for posting your findings.

@jswerdfegerI am experiencing this issue with one of our employees as well who is the owner of the Team and Channel. There is only one channel out of the 20 channels under that team though experiencing this issue where members cannot post new conversations/messages. Results with message send failed.

I created a test channel in same team with same permissions and it works for members to post. So if we were to delete the channel and create a new one it would most likely fix the issue, but she does not want to lose the Channel chat history (and doesnt want to just copy paste it all)


Did you find out any answers from the Microsoft Support ticket you submitted? Hopefully Microsoft had an easy fix for you like something simple as them pushing a button on their end.


A reply would be much appreciated so I don't waste time with MS support going through hoops to troubleshoot.





For anyone else who finds this thread and is having this issue, these are the steps provided by Microsoft Support that fixed it for us:


  1. Sign in as an owner of the Team
  2. Right-click the affected private channel and select "Manage Channel"
  3. Go to the "Settings" tab, and expand "Member Permissions"
  4. Toggle the "Allow members to create, update, and remove tabs" control. If it is checked, uncheck it. If it is unchecked, check it.
  5. Wait for a moment, then revert the control back to its previous state.

After following these steps, channel members were able to post in the channel again, and we luckily did not have to create a whole new one.