Meeting Attendance List

Contributor

Hi All,

I've seen the uservoice for creating an attendance list after a meeting https://microsoftteams.uservoice.com/forums/555103-public/suggestions/33989875-view-or-export-a-list... 

They mention they've enabled downloading an attendance list, but helpfully not explained how.

Anyone know how it's done?

Thanks

53 Replies
You need to enable it via PowerShell:
 
Set-CSTeamsMeetingPolicy - Identity Global - AllowEngagementReport "Enabled"

Adam

@adam deltinger Thanks. How do you then get the report from the meeting?

@adam deltinger Also, I'm getting the following error. I'm using an administrative PowerShell session, and have installed the Teams module.

 

Set-CSTeamsMeetingPolicy : The term 'Set-CSTeamsMeetingPolicy' is not recognized as the name of a cmdlet, function,
script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is
correct and try again.
At line:1 char:1
+ Set-CSTeamsMeetingPolicy
+ ~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (Set-CSTeamsMeetingPolicy:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

@CMSCMSCMS  Teams policy cmdlets are in the Skype for Business Online PowerShell module. Download and install that module and you'll be able to use that cmdlet.

You need the Skype online module for running this command

@adam deltinger Thanks. I've installed that, and tried following the guide here to connect. When I run the command I then get a prompt to connect. If I put in my same admin credentials I get the following error:

Exception calling "GetSteppablePipeline" with "1" argument(s): "Cannot bind argument to parameter 'Credential' because
it is null."
At C:\Users\Administrator.ADMIN\AppData\Local\Temp\tmp_p3r40rbi.vra\tmp_p3r40rbi.vra.psm1:45143 char:13
+ $steppablePipeline = $scriptCmd.GetSteppablePipeline($myI ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : CmdletInvocationException

@adam deltinger I've managed to at least get connected on a different PC. When I run the command I get the following error, so it seems to be struggling to pick up one of the parameters:

 

PS C:\WINDOWS\system32> Set-CSTeamsMeetingPolicy -Identity Global -AllowEngagementReport "Enabled"
A parameter cannot be found that matches parameter name 'AllowEngagementReport'.
+ CategoryInfo : InvalidArgument: (:) [Set-CsTeamsMeetingPolicy], ParameterBindingException
+ FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.Rtc.Management.Internal.SetTeamsMeetingPolicyCmdlet
+ PSComputerName : admined2.online.lync.com

Might be that the feature is rolling out early May! Also it will be available as a download button in the attendee view in the meeting

@CMSCMSCMS The parameter to allow a meeting list to be extracted is not yet deployed. When it is, you'll be able to update the policy.

@adam deltinger @Tony Redmond Thanks guys. Is this part of the PowerShell functionality that's in preview?

@CMSCMSCMS No. That's the Teams module.

 

The Skype for Business Online module is a stub. It connects to the endpoint and makes the cmdlets available to a session. When the endpoint is refreshed, you'll see the new cmdlet parameters.

@Tony Redmond Sorry, not sure that that means! By the Endpoint is that referring to Teams? So when the Teams features are out of preview the command will be available?

@CMSCMSCMS The endpoint is where the module connects to. In this case, it's the Skype for Business Online endpoint because Teams uses it for its policies. (historical reason, too boring to discuss).

Hi, when i try the command i'm getting You are not permitted to invoke Set-CsTeamsMeetingPolicy with the following parameters: AllowEngagementReport

what am i missing?
Thanks!

@m_cassar83 Probably the feature hasn't yet been enabled in your tenant.

But when I use the Get-CsTeamsMeetingPolicy, I see it listed. Could it be that it's still not enabled?

@m_cassar83 Just because a cmdlet is updated doesn't mean that Teams is able to set that policy for your tenant. There are many moving parts that need to link up before features are completely enabled 

When your tenant is moved to Teams Only mode is the ability to change SfB Online Policies blocked?

I am the Global Admin and I just tried to make the change and I receive;

"You are not permitted to invoke Set-CsTeamsMeetingPolicy with the following parameters:
AllowEngagementReport"

 

We have been in the Teams Only mode since April 5.

 

@Forrest Hoffman 

I have the same error, but we're not teams only.

 

I guess it's because it's not available yet.