Mac - A javascript error occurred in the main process

New Contributor

Screen Shot 2019-05-15 at 11.09.57 am.png


I've tried installing Teams for Mac a few times now and each time I end up with this error screen and the app never loads. I'm going to assume there's a conflict with something on my system, but I've no idea what or where to look.

Running Mojave 10.14.4 (18E226) on a MacBook Pro.


27 Replies
Seems like a permission error for user “contagious” ? , trying to create a directory for installation...

Do you have admin rights?
I’m MAC you need admin permissions!

From official doc:
(admin rights are not required to install the Teams client on a PC but are required on a Mac).

If you are, get the logs and let us know:

You find the location of them here:

@AdrianR Facing the same issue also!


Screen Shot 2019-05-20 at 3.11.29 pm.png

@adam deltinger - the app doesn't even get far enough to start creating logs. The Teams logs folder doesn't exist let alone the log file.


I have admin rights, and the app correctly prompts for access permissions when it installs.

The installation appeared to be successfulThe installation appeared to be successful


Looking in to the error message it's complaining because it can't create the folder ~/Library/Application Support/Microsoft 


Checking what was there already it turned out the folder was owned by root and not the current user like all the other folders.


The Microsoft folder was owned by root rather than the userThe Microsoft folder was owned by root rather than the user

Looking in to what could have caused that, I had an ancient Silverlight folder in there. No-one needs that, so let's kill it. rm -rf ~/Library/ApplicationSupport/Microsoft and try running Teams again and I got the same error. Repeated the process one more time to be sure and it all started working as expected.



An old installation of Silverlight messed up the permissions on the folder. Deleting the Microsoft folder and letting Teams add the folder back itself solved the issue. 


@AdrianR I had same issue and just did sudo chown yourusername Microsoft from ~\Library\Applications Support\ directory and it worked straight away.

@Divergent_Technologies I have had the same javascript issues and the same message coming up when I try to open teams. I have also tried to follow all the steps outlined above, changed permissions, etc. and the same thing happens. Any ideas?



...same here. I haven't the faintest idea what else I can do. I have to work online with my colleagues because of the Corona crisis, but I can't because the teams app doesn't work. I have also tried everything that has been recommended here.

Hooray, error found! There are 2 library folders (of course!). Go to HD > Users > (yourname) > Library > Application Support > Microsoft. Set the permissions to your username: sudo chown (yourname) /Users/yourname/Library/Application\ Support/Microsoft

Teams works now

@Angel1060 could you please explain HOW to do what you have described thanks?

All I have in this folder is a Silverlight folder????

How do I set the permissions to your username: sudo chown (yourname) /Users/yourname/Library/Application\ Support/Microsoft?

@Angel1060 could you please explain the steps required to do this?  I am also having the same issue and went looking for the library folder under my username but I don't have one?



@AdrianR has the SOLUTION : "Deleting the Microsoft folder [ in Macintosh/User/Yourusername/Library (if invisible  just write

AppleShowAllFiles true

in the terminal)

/Application Support/Microsoft (the one to delete) ]


and letting Teams add the folder back itself solved the issue."


The sudo chown command in the terminal didn't work for me.


Thank you @AdrianR !


@nathan333 @AdrianR 

Still having the same issue, just went into macintosh/library/application support - and I deleted Microsoft and then emptied my bin. 

Teams is still not opening getting the same error. 

Please help, I have no idea about the terminal and any of the coding stated above.

Ditto - still can't get MS Teams to work

this worked for me

uninstalled Teams

navigated to folder Macintosh HD/Library/Application support

'Get Info' on Microsoft folder


Changes ALL Sharing and Permissions to Read & Write

Screen Shot 2020-04-19 at 21.52.52.jpg

Then reinstalled Teams

Java error disappeared!


Good luck

Thanks everyone for your ideas above :)

@figjamgle I tried it but still does not work.  What do you have in the Microsoft Folder?  

This is the solution:

there is a chance that the Teams folder is not created successfully. To check it, please navigate to the folder location /Users/(your username)/Library/Application Support/Microsoft/ and check if there is a folder named Teams. If not, please create it manually and then reopen Teams to see the result.

@Paolo_C Have you fixed this problem yet please? It's now doing my head in. I'm so frustrated. I seem to have tried everything. Still can't get Teams to work. Help!

@GBaussie I had success!


I followed the path name at the top of the javascript error. Its like it was trying to install into a folder that just wasn't there. So like a few other posts mentioned I created Teams in 


MacintoshHD>(your name)>Library (this folder may be hidden - right click for view options - Show Library Folder)>Application Support>Microsoft  (then add Teams folder) restart Teams and it will populate that folder and open.)


I hope it works for you






hi TCG,


Ive tried all suggestions.  Still can't get it to install, Really confused now.


Works OK through my Chrome browser and on my iPhone, just not on my Mac.


Here's some info. What am I missing please?




i have the same error message with teams

I am using a mac airbook and cannot find or access the folders you are quoting

when i type them into my finder.