Lost access to Files in Teams

New Contributor

We can no longer access any of our files in the free version of teams.  When we try to navigate to the "files" tab in any of our channels, we receive the following message:

The specified list is invalid
The specified list might have been deleted or you might not have permission to view it. Contact the site owner for more information.
How can we regain access to our files?
7 Replies

Hi @Mike_Santee ,

Has anyone gone into the underlying SharePoint site and either 1, changed permissions or 2 removed the folder that is the container for a respective channels content?

So I would go to the SharePoint site that backs the files tab, that in the commercial version is easily accessible by way of clicking open in SharePoint.

However.....wait a second you are using the free version and I don't believe that to be an option. However and I feel dirty for doing this but I did start to access the SharePoint site behind the scenes.

So back to my original point, knowing it is indeed possible has someone perhaps interfaced with the underlying SharePoint site of the Team in OneDrive for Business or accessed the SharePoint site directly and changed permissions or deleted the channel folder?




@henryarphillips365 Henry, thanks for the response.  No one in our organization has accessed a SharePoint site and I do not believe that anyone erroneously deleted all the files in the Team (for all channels); we seem to have lost access to the files between the time we left work and came in the next day.  None of our members with "Owner" rights would have been active on Teams during this time.

Any other ideas how to regain access to the files?  Anything helps!



Hi @Mike_Santee ,


I would recommend contacting Microsoft support but in the meantime I will private message you a potential workaround to at least access the files and perhaps as a short term if you created a new Channel. In fact that is a good point if you created a new channel, does the files tab function as expected in the new channel? Presuming it does you could put the files there.






@henryarphillips365 I contacted Microsoft support and I was directed here for a solution...


And to your suggestion; I was unable to post files in a newly created channel.



We are having this same issue.  We're using the free version of Teams.  The issue has affected everyone.  The files aren't on the sharepoint or on OneDrive.  I get the same result on the web app and the desktop app.  I may be checking the totally wrong Sharepoint/OneDrive.  I'm not sure which one to check. All the ones I have checked, are empty.


I get the "unknown error" when trying to access an xlsx file that we turned into a channel tab. We also get the message "the specified list in invalid" when accessing the "Files" tab in every channel. 

Best Response confirmed by ThereseSolimeno (Microsoft)

Hi @rpkin ,


The problem with the free version is that a lot of the behind the scenes stuff is hidden away and there is no way of easily accessing or changing these areas. So when we talk about files in Teams in the context of a Channel we are talking about SharePoint Online and when we are talking about files personal to that of a user or in the Chat area we are looking to OneDrive for Business (technically SharePoint still).

Now issues aside in the non free version, each of these behind the scenes elements such as:


M365 Group

Exchange Mailboxes

SharePoint Online

OneDrive for Business


Are all accessible independently which makes troubleshooting far easier but which also leads me to probably suggesting you raise a support case as we are talking about areas of the free version that Microsoft have purposefully obfuscated.

I did manage to find a hacky way of getting to the underlying SharePoint site behind a free Teams Team, but as for @Mike_Santee he was only able to get so far and probably due to the same reason it is not working via Teams.


Whereas when I was able to, I did not face an issue.

So I would raise a case with Microsoft if possible as 1. This seems to not be just impacting 1 person and 2 there is not a lot you can do in the free version.

I suppose one thing I did think of the other day, is if there is some sort of credential conflict. So do you also have other accounts that you use to access other M365 tenants/services? If so, could you go into an in private browser session or incognito and go to as your pure free Teams account and see if you have any better luck?

If you want to private message me and are willing to do so I wouldn't mind having a screen share with yourself to see what we can find out if the Microsoft support route doesn't get you anywhere.







Thanks for the reply.  I tried to raise a ticket with MS Support but was directed here instead (since we're using the free version and they aren't providing support). 


I was able to do some more digging and found how to access the sharepoint site that is serving our free Teams accounts.  When I attempt to access it I get an error stating that the domain's "server IP address could not be found."

After cross referencing that result on the Sharepoint "self-help" community I found this post: in which @Chris Webb mentions that the "Sharepoint tenet or something" was likely deleted.  His recommendation was also to contact support.  I have raised this with our 3rd party support consultant hoping they can help push this through MS Support past the barrier I hit. 


I will update if I get any results. I'm all ears if you have any other suggestions.