Login problems to different organization

Copper Contributor



I have a coperate teams accoung and was invited to join another organization. But I cannot access it. The company is listed in the menu but when I click on it I either end up in my organization or I have to completly relogin and than end up in my organization.

My coworker has also an invitation and he can change the organization.

What am I missing?




6 Replies
Hi, how's the behavior if using Teams online? If it works there you know it's the desktop client. There are some general troubleshooting steps such as clearing cache, reinstalling, reset all autostart settings, remove account from W10 settings etc. you can try if it works using Teams on the web. Let me know.

@ChristianJBergstrom Thanks for your answer!

It is the "same" problem. I click on the other company and after some reloads of the page I end up again in my organization. 

I also installed Windows from scratch on a test machine. Same problem :(

Even if using InPrivate / Incognito in your browser? Perhaps you should try and leave that org. and ask for a re-invitation.
I just used the Incognito mode in Chrome and that does not help either. A reinvitation we also tried some days ago.
best response confirmed by ThereseSolimeno (Microsoft)
Have you tried to have that organizations admin to permanently remove your guest account from their Azure AD? First a deletion and then removal from AAD bin. Wait 24 hours and re-invite.
We have not tried that. I will inform them to try this.