Launch it Now link in browser does not work.

Copper Contributor

When I get an invitation to a meeting, I get a link that looks like this:


I click on it and browser window comes up that looks like this:


Then I click on the Launch it now, but it does nothing.  So effectively, when invitations to meetings are sent to me, I cannot join.  Why will the teams not start when clicking on Launch it now link?


Edit: some investigation shows that the link contains no address, see below:






16 Replies

Do you have the desktop Teams client installed? Clicking the link basically launches the desktop client, if you do not have it installed simply click the "Join on the web instead" button.


P.S. The link doesn't "need" to have an address, it has an event handler attached to it that takes care of things. In other words that's not a problem.

@Vasil Michev , yes I do have the team client installed.  What is interesting is that it does not work on my windows machine, but works fine on my Mac.  OK, so how does the link trigger the opening of MS Teams?  Are there configurations I need to check?

@silver_diamondSame thing is happening to all the laptops in our office so it is definitely a bug that MS needs to sort out.

@AWillsSame thing is happening to me, no reports from the office, yet, but I make sure I am ahead of the curve, so I see these things first.


Workaround for me is to copy the link into a Teams conversation and it goes straight in from there.


MS fix this... (please!).

Do we have an fix for this issue?

Any movement on this? Seeing the same functionality (or lack of) here.

best response confirmed by Grahmfs13 (Microsoft)


Make sure Teams is your default handler for all the types it is capable of. Settings->Default Apps->Defaults by Apps:




Solution (that worked for me):

I've had this issue for months... tried reinstalling and all sorts however reading some of the responses below lead me to my solution.


As below:  Go to: [Settings] > [Apps] > [Default Apps]

Note:  At this point I couldn't set the 'apps by protocol' because 'Teams' wasn't showing as an option to choose against each protocol.

Instead: Next: I chose 'Set Defaults By App' and scrolled down to 'Teams'.  Clicking on 'Teams' gave me all the options that I could default 'Teams' for and I clicked them all.




Now when I click on a Teams link in an email/web it works!


Good luck and I hope this helps someone else too.


@Plan3tBob I did specify that 'Defaults by Apps', and my screenshot which you used, is that exact screen.


My post should be marked as the solution. Dont be that guy who steals others good work and passes it off as your own!



Thanks it worked!


How can this be done in windows 7?

@Nickl99, how did you get into Setting and Default Apps? I am unable to find it via my Mac.

@Grahmfs13 I'm working on this too and not finding the starting place for those instructions either

This solution did not work for me. I click a link, it opens a tab with gray background, nothing happens. Everything is set to default but Chrome will not pass the link.

Mac doesn't have one. You'll need to ask on a mac forum; try facebook groups.

I ran into the same situation; I click a link, it opens a tab with gray background, nothing happens. Everything is set to default but Chrome will not pass the link.