Joining a call from a link via the app

New Contributor

Hi, I'm having an issue with joining meetings from a link. Instead of a meeting request, some of the calls I'm asked to join come via a link that's been forwarded to me. When I click the "click here to join the meeting" link in the email it opens my browser with the options to join via Teams web, download the app, or open my app. I have the teams app, but when I click to open it from the browser nothing happens and they only way I can join the call is by using the teams web browser app, which doesn't have full functionality. Is there a way to fix this so I can join a meeting from a link, (not scheduled appointment) within my Teams app, or switch from the web app to the Teams app when I've had to join via my browser?

3 Replies
Any chance you're on a Mac? What troubleshooting have you tried so far? I would probably start by reinstalling the desktop app. If that doesn't help do some manual removal of every location described here and then reinstall

~/Library/Application Support/Microsoft/Teams/ (Mac)
Thanks for your reply! I'm on Windows actually. Have tried uninstall and reinstall but not good.
Ah, ok. Try wiping all content here and install again.

While you're at it remove all browser cache as well.