'Join Meeting' button missing - Can't Join Teams Meeting

New Contributor

Hi there.
I have a problem when I try to join any meeting in Microsoft Teams on my laptop. This problem persisted for more than 6 months. I searched for discussions on bugs and other things but I didn't find something that matched my situation. And there's no way to report bugs in the application.

I have a student account on Teams that is managed by my University. This information might be useful later.


Basically, what happens is that I see when someone starts a meeting but I don't see the "Join Meeting" button. If I don't have a link to the meeting I just can't access it. The button just isn't there. I tried joining on my browser but it shows me that there is a problem when signing in. This might have something to do with my account that is managed by the University.

So far I have tried to:
-delete the cache;
-reinstall the app (I tried this at least 4 times);

-install the Home version;

 

All of my attempts were unsuccessful unfortunately.

 

If you have any idea on how to remedy this situation please share. Have a great day.

2 Replies
I found a solution to the problem.
I have adjusted my time zone and I can now see the join button. All I had to do was choose my correct timezone, it had nothing to do with cache or things like that.

I found this out accidentally (and just today, after weeks of searching for a solution, an old thread popped up with the exact problem).
This also is an issue in our class. The meeting in 'general' would only be visible for around a minute or so, and it would just disappear. The problem is each of our timezones where exactly the same so I don't know what's going on. Hope this gets fixed soon.