Join Button in Outlook no longer joins meetings

Copper Contributor

I'm on MacOS with old Outlook and New Teams.   The "Join Online" button in Outlook has stopped working.  Clicking it will bring the focus to Teams but will not initiate the actual meeting join process.  Switching back to the Old Teams solves this.

Any suggestions for fixing this? 

13 Replies
I have this problem too. Makes it difficult to start meetings. Everything worked properly until I installed the new Teams for MacOS. Teams version is 23272.2708.2452.9689. The client version is 50/23092912310. (Not sure what the 2 different version numbers mean?).

@KCBaltz I'm getting the same thing ever since I moved to New Teams for Mac last week.

For those having the same issue with New Teams, are you on Old Outlook or the New one?

@KCBaltz Im using Outlook for Mac v. 16.78.2 (23102103) which I believe is the latest at the moment (Oct 2023)

New Outlook. It is still an issue with Outlook version 16.78.3 (23102801) and Teams 2372.2708.2452.9689 (client 50/23092912310)
any updates? I have this now too with the 'new' teams :(

@KCBaltz I'm having the same problem.  Any news?

I was able to fix this by uninstalling the 'teams classic' from my desktop.

Maybe this will help you as well..

@Dthacker  I went back to Teams Classic and have stayed there for now, so I'm not sure if this is working better yet or not.  

This worked for me, thanks!
good to know it works fro mac too @ShabsRUK my fix was on windows :)

@KCBaltz - This started happening to me in the last few weeks. It's only if I'm using OLD Outlook though. If I switch to NEW Outlook the join buttons work. 
Not sure if it started happening because I was on NEW Teams but OLD Outlook (does new Teams only work with new Outlook?).

@Amber_Skidmore I'm still using OLD Outlook (because they won't fix a bug in the new one) and have now migrated to NEW Teams without issue. The Join button is now working for me.