JavaScript Error when Starting Teams

Occasional Visitor

I have a user unable to open the desktop client of Microsoft Teams.   He receives the following error when trying to start the Application.  He can use the web version of Teams but is unable to use the Desktop client.  I tried an uninstall and reinstall which didn't resolve his issue.  

Teams Javascript Error.jpg

 Use is using Windows7 and the 32-Bit Version of Office 365.  

12 Replies
Clear all folders in the appdata url you see in the error message! Do a full install again

I had this exact error today, if anyone is reading this in the future. @jhailey 

The user in question didn't have permissions to the AppData folder. Once permissions were given to the user it solved the issue!

Tengo el mismo problema me aparece Java error @Oakenbear  No puedo instalar microsoft teams ya instale y desinstale, como veo el appData??


How do I find de App Data carpet?


@Oakenbear how does one find the AppData folder?


I have the same error for Microsoft teams but I am on Windows 10 so if anyone knows how to solve this same problem on Windows 10, please tell me.

best response confirmed by ThereseSolimeno (Microsoft)

@Amy_Johnson easiest way to find the AppData folder is to right click on the Windows Start button, select run, then entering %APPDATA% and pressing Enter. The shortcut key to get the run command is Win+R.

AppData is located in C:\Users\<yourusername>\AppData


It is a hidden folder

Good afternoon all,

Just had this issue and after trying to only uninstall teams and removing all files and linked to it (Still No Luck) I uninstalled Office 365, restarted the machine and ran throught the O365 install again. Restarted and then installed MS Teams and it's worked.  Restarted a few time to make sure it still loads.



Hope This Helps

@Dra_Laura I am desperately trying to get back into Teams. I am having difficulty in doing so because I am not an IT person. I am a teacher. I can navigate Teams when it works, but I'm afraid that when it doesn't I am well and truly scuppered.

@jhailey I'm also having this issue but on mac, has anyone found a solution?

Not shure if this works for windows 7, but i know it does for windows 10.

The easiest way is to use Windows key + r, then type %appdata%