Incoming Webhook - This card action is disabled...


Hello everyone,


I'm facing a small probelm with the Incoming WebHooks in Teams and hope someone can help me.


I have created a Incoming Webhook for a on premesis 3rd party application (Seq) for posting log information on critical errors to a channel in our Teams environment. The webhook was easy to setup and the messages gets posted to my channel like they are supposed but I'm unable to open the action link in the posted message. When i click the action button in the posted message a "This card action is disabled because Seq has been blocked by your administrator" error message is displayed in the upper edge of the Teams channel.


Has anyone else had this same problem? Any ideas on how to fix it?

26 Replies
I'm seeing the same problem.

I'm seeing the same on Visualstudio TeamServices notifications where it add's a button "View Check-in" This buttons started after the last update, becuase previous Check-in notifications did not have this button/ Must be a new feature that is not working properly yet!

Anyone found a solution for this yet? One of my clients are receiving the same errors with Zendesk and Wunderlist applications.


I've attached the error the client is receiving in Wunderlist.

It is a permissions thing, and it is buried and non-specific. Go to your admin console, then go to Services and Add-Ins, Microsoft Teams, Bots & Tabs. And enable the options there, and Save.

Oh, then you need to reload the webpage if you are using web teams, or exit and reload the desktop app for the changes to take effect.

I did that, and restarted Microsoft Teams App but my View check in buttons still do not work. They don't say it's a security issue but simply don't do anything. I enabled the bottom one that was still Offiexplore_2017-03-23_13-15-04.png




I have Visualstudio connected and the hyperlink on the changeset number does work (it opens the website of VSTS for that changeset, but the new View check in button does not work... Teams_2017-03-23_13-19-42.png





We're having this same issue. @Soumitra Paul this is what I was messaging you about :)

This is the answer. Our admin made this change and now the actions/links are working!

This worked for me, thank you very much for your help!

Strange as I pointed out it did not solve the issue for VSTS. Did you have the options I put in the screenshot enabled and it worked. For me I do not get the disabled notification in the top but the View check in button just does nothing.

Yes, I activated those two and fter that I had to log out from Teams. When I logged back in it worked fine. I have also one post with a button is not working, it simply does nothing, but so far it is only one...

So now I'm also having this problem with my links, none of them work anymore! Did you find a sulution for this?

Nope still no buttons work. Today I unchecked both checkboxes and saved, then logged out of teams, checked both egain and saved. restarted teams, no change. I'm not sure whether these checkboxes have anything todo with this problem, or there are more factors involved. But it seems nobody cares, or it's just a small portion of users affecterd :(

The buttons on the webclient open a new tab without url. Would''t that suggest the problem might be on the source side where a card is generated without proper links?
Looking at the browser console for a page with card buttons to Visualstudio logs a lot of "Invalid URL received:" messages

I'm also noticing this now. I had not tested it in the webclient before. However, some links from the same 3rd party app are still working...but only a few...



I dont see the bots and tabs settings.  Can you still see it under your admin portal?



It looks like the tab has been renamed to "Apps"