Incoming Webhook - MS Teams returned HTTP error 403

Occasional Contributor



I'm sending log information from my application directly to MS Teams channel. The problem is that it stopped working around one month ago. When I try to send POST by using Postman, I get error 

Webhook message delivery failed with error: Microsoft Teams endpoint returned HTTP
error 403 with ContextId tcid=8329146558657309443,server=EAP010230157048..


I was trying to search something about it, but I didn't find anything.


Any ideas?




10 Replies

Not sure if related in any-way, but for about the month I've been working on it SPO has been delivering malformed JSON from it's web-hook to my server. Maybe something has broken on the web-hook side of things?

Is this a webhook that is older? or a new one and where do you use it?

It looks like that Incoming Webhook connector is not supported anymore.

At this moment there are just a few connectors available


Just checked in 3 different tenants but the option is still there

Hmm I don't know what's wrong, but I still see the same connectors as I've posted before. I've also tried to run MS Teams in a web browser, but no difference.


Btw. I've checked Console window of Developer Tools and there are a lots of JS errors


it seems you have some issues. I get some errors on JS that is referring to calling which is not there yet.

I also see some 401's at your screen are you the admin?

I've tried both accounts (admin and standard) and there is no difference.

best response confirmed by Lukáš Kubis (Occasional Contributor)

In order to see the connectors that disappeared, you have to (as an admin) go into your tenant settings and under Apps turn on "Enable new external apps by default." An update in August added Connectors to Apps and turned off external apps by default. We turned this setting on and restarted Teams and the connectors showed up. See the blog post about it here:


Finally it started to work when I had enabled Incoming Webhook connector. No more 403 errors :)

How have you enabled it?  I am getting this below error while trying 


webhook message delivery failed with error: Microsoft Teams endpoint returned HTTP error 403 with ContextId