I am the meeting organizer, but Teams will not allow me to access Meeting Options

Copper Contributor


I am a teacher and I schedule my lessons on Teams. Today, I encountered a new issue. First, let me clarify that I am logged in with the same account on the app and the browser and I have gone through cleaning my browser history several times.  So, here is the problem:  I scheduled three new meetings.  I am the organizer of  all three meetings (same account). I was able to change the Meeting Options of the first meeting, but when I clicked on Meeting Options for the other two and I got a message that reads: Only meeting organizers can make changes
Your account, xxxx, doesn't have permissions to make changes.


I tried accessing the meetings through Teams (app and browser) and through Outlook, but I get the same message.  All help will be greatly appreciated. Thanks!

37 Replies

@YesimNuman Hi, I've seen that a couple of times before. Usually you just have to do a manual sign out / sign in from the top right corner (online and desktop) and/or clear the cache as well.


Let me know how it goes.

Thanks, @ChristianBergstrom but I've already done all that multiple times.  Still the same.  Weird thing is, the email address in the message (Only meeting organizers can make changes. Your account, xxxx, doesn't have permissions to make changes.) is the correct email address.  When I open the meeting details, I see the same account as organizer.  Not sure what is going on. 

It's usually a browser token issue, I always had to open incognito browser and copy the link that goes to the meeting options and use it there. See if that works.

@Chris Webb Just tried that.  Didn't work. Thanks anyway.  

The other 2 meetings, did you tie them to a channel? Channel meetings don't have the same meeting options as regular meetings and would probably lead to this, just something I would think outside of some kind of bug that would cause an issue.
I just created a Test channel meeting and options still come up so doubt that would be it. Reoccurring? Anything different about those meetings that don't work?

@Chris Webb No channel. I created them exactly the same way that I created my other meeting today... and the same way I created all my meeetings last week.  So frustrating.  :(

@YesimNuman: Did your problem get resolved?


A colleague had the same issue when she tried to create events through outlook. It looks like it was interfering with the 2 IDs she uses. Then she logged into the account via a private browser and created the event from the calendar. It then allowed her to edit options too.

I've had the exact same problem @YesimNuman 

I did some tinkering and found - by sheer fluke - that it depended whether I'd added the Team meeting in my Teams calendar or in my Outlook (i.e. email) calendar


If I created the Teams meeting in my Outlook calendar then whenever I was working in the Teams desktop application, it kept telling me I didn't have the rights to delete/edit the meeting.  Also if I tried to join the meeting from the Teams app I got a message saying someone would let me into the meeting soon.  These are meetings I had arranged, from the same account.


Really frustrating - but now I just arrange all meetings in the Teams calendar and join the meetings also via the Teams application (desktop or phone).  And if it doesn't work, I know to try going in via my Outlook calendar because I've obviously had a brain fade and forgotten my own rule ;) 


Yes it's stupid and it should sync - it's the same account, after all - but maybe tech isn't as smart as we'd like to think!!  Hope this helps. Stay safe.

I am meeting organizer but team will not allow me to access meeting options

@Avantika_Singh I just ran into the same thing. I was able to access Meeting options by joining the meeting and then selecting More options. From the More options drop-down I selected Meeting options. It opened the Meeting options pane and I was able to make changes.

Hope this helps.



I am experiencing the same issue as an organizer (error message 'Only meeting organizers can make changes. Your account, XXX, doesn't have permissions to make changes.') Of course, I tried all the suggested options listed above (deleting history / logging out of the app/ incognito and regular Edge/ copying link etc.) several times, but for one of the meetings it still does not work. Can you please let me know if you are aware of any other solutions? Thank you. 




Unfortunately, I could not find any solutions and had to delete the sessions. As far as why this happened, I didn't get anything that is more substantial than "it must be a glitch". 

@YesimNuman thank you. So sorry to hear about your experience. :( I was hopeful that this issue got sorted out by now. I cannot cancel the meeting as the invite has already been shared. 

I was able to bypass this error by changing the default web browser. I usually use Firefox, so I changed my default browser to Edge in Windows settings. That made the trick.

Thank you @Mediakimuli, I tried this but it did not work for me

How did you go? @NiStu1280 

I had exactly the same problem. I'd created the meeting in outlook & shared it from there (external people). When I went into my Teams calendar to update the meeting options it took me to the web browser & gave me the permissions error message.

So after reading one of the other comments, I started the meeting (from my outlook calendar) and then could access the options from there. 


A bit of a roundabout way, but it seemed to work. 

@YesimNuman Hi, I have the same problem and just cleared the cache of Teams.


If you're using chrome, just go to Settings > Privacy and SecurityCookies and other site data > See all cookies and site data.


On the search box, type "teams" you should be seeing like the one below:



Then click Remove (trash can button)


Please note that this may log you out. Just re-login and try accessing the meeting options again.


Hi @daryl15 . I tried that several times. Did not work.  I had to delete the meeting and redo it.