How to Join a Teams meeting from an external company on IPhone or Ipad

Occasional Contributor

We use Teams extensively within the company but have an issue with joining externally created meetings. When an invite arrives from another company (also using teams) we can accept the meeting and it sits in our teams calendar just as an internal invite would. However when clicking on the join meeting link in the invite this opens the browser where (on PC or Mac) I can select to open the meeting in Teams or use the browser. 

The issue occurs when I am using an Iphone or Ipad with the teams app. Clicking on the meeting opens the browser but does not have the open in app or browser option. instead the meeting is joined in the browser and displays the "Your browser does not support teams meetings" message.  very annoying as I have the Teams app installed and would excpect to join in the app as I would with internal meetings. 


How can I join external Teams meetings where the invite comes from another external company on my Iphone or Ipad device. 



27 Replies

I haven't noticed any issues with joining external meetings on my mobile (using Android), but if you can reliably reproduce this open a ticket via the app (Settings -> "report an issue"). 

Yeah I recall it opening fine as long as the teams app is installed. Some possible work around would be have the user open teams and use the calendar in teams to join the meeting which should open it in the app directly.

I do use outlook thou which has join buttons. If they are using iOS mail or something it might just be presenting the ULR to join could be why. Best bet might be to use teams to join in that case. I’ll need to setup a test myself and see what happens.
Just tried every which way to join meeting from external tenant and every time it opens the Teams app just fine never goes to the web page. This is for iOS.
Hi Chris.
Thanks for checking.
Very odd.
I will run some more tests and perhaps get the user to reinstall teams.
Thanks again.


Hi there,

I realise this is an old post but I am experiencing the very same issue. Did you happen to find a solution?

Thank you. 

Actually we have not had an issue recently. In the iOS mobile app for teams in the menu you can scroll down and switch easily between accounts.


Thank you for taking the time to reply. I don’t have a problem through my iPhone, only through my iPad. I’m running the latest version of iPadOS if that makes any difference. It’s very odd. I cannot view through the webpage either, the same issue as mentioned earlier in the thread. 

i am having this problem too.  I have sent myself a teams invite from my work account/email/pc to my personal email address.  When i open the invite and click the 'join meeting' it opens Safari and gives me the same cant join message.


it is an older ipad so i can't download the app, so joining by browser is my only option.


anyone found a solution?

Mobile Teams is only supported via App. You cannot use the browser to access Teams.

I'm sorry, but it's EOD and my brain is broken: re: the previous poster,

"i am having this problem too.  I have sent myself a teams invite from my work account/email/pc to my personal email address.  When i open the invite and click the 'join meeting' it opens Safari and gives me the same cant join message"


- we are finding the same exact thing today and it's a problem bc we want external attendees to be able to join MS Teams meetings from their mobile Apple devices without downloading the Teams app.

Am I to understand this simply isn't possible? They must download the teams app?

Correct you can only join on mobile if you have the app installed. You do not have to have or setup an account thou. Just the app installed.

I’m having the same issue on the iPad, I click the link and I”m taken to a download page instead of the app. If I use my mobile it goes straight to the app and joins the call.



Only things I can think of

1: Reinstall app?

2: where are you opening the link? Outlook? Do you have a different browser set to open links there? If so maybe try copying link to Safari instead or if it is in Safari, try opening Chrome / edge if you have them (or download if you don't) and pasting in link and see if that makes a difference. Maybe there is something there with the browser or app you are using to open the link. Instead of clicking try copying the link and pasting into different browsers and see what happens.
I just tried reinstalling the app but it hasn’t resolved the issue. It takes me to the Teams online page where is has a link to launch in the app but when you click it there is no response.

I’ve tried opening the link from my calendar, copy-paste into Safari. I don’t have google or edge on my iPad.

If i copy the link into a teams page and click from there it allows me to join the meeting in the app.
Seems like your iPad is under some form of Locked down state, is it tied to a company mobile MDM or anything? Do you have any kind of so called Antivirus type software on the device managing any kind of security?


I was having similar issues on my iPad but found you can launch the app from any link as long as you open it through Chrome. iPad will always automatically open the link through Safari but just press the little ‘up’ arrow (I don’t know the official name) and select Chrome. From there, launch the app. It has worked every time for me but you will of course need to install the Chrome app. 

Hope that helps. 


Thanks that works.
Annoying that Safari doesn’t work but a great workaround!

Well I did suggest this a few responses back ;). I always use outlook for mail which allows opening links by default in another browser. iOS is supposed to allow that I think in next iOS update hopefully.