How to fix this add to contacts error?

Occasional Contributor

teams bug.png


This happens when adding people to favourites. I can't find any documentation on this. Please advise.

27 Replies



Can you add contacts to other groups? Is it the same problem when you add Internal contacts and External? Did you enter the full SIP/mail address or did you search for the name of the contact?



Hi @Sim00,

A few quick questions

1.) Does this happen in both the web app and the desktop app?
2.) Is that a user in your org? Or an external user?
3.) Have you completely logged out/restarted Teams and does the issue persist?
4.) Is it just the favourites group or is it custom groups too?
5.) Is your Teams client up to date (latest version)?

Look forward to hearing from you.

Best, Chris

@Christopher Hoard 

@Linus Cansby 


  • I also cannot add contacts to other groups not just favourites
  • I've only tried (and know) internal contacts
  • I clicked "Add a contact to this group" and tried various staff in the office
  • It is affecting other employees
  • My installed build is unknown, but the last date on the Help -> What's new tab is 25 January.
  • I have successfully added my colleague who set it up/is office admin. The above error still occurs for any other name. He is also unsure why we are getting this error
  • I have logged out/restarted
  • When visiting the web app link I get "Someone has already set up Teams for your organization" and unable to progress further

Many thanks

Hi @Sim00

Thanks. A few more questions -

1.) Are you using a paid version of Microsoft Teams (with Microsoft or Office 365) or the free version?
2.) Are you logging in with your work address (I.e. or your personal address (I.e.

Best, Chris

@Christopher Hoard 


  • We are on free with a view of migrating to full Office 365
  • Work address




You should be able to sign in with the same account at as you sign to the Teams client.


In your Teams client check the version by clicking on your profile button in the upper right corner and select About > Version. You can also check for new updates by selecting the profile button and select Check for Updates in the menu.


I started my Teams Free setup now and tested and did not have any problems adding contacts. Since you are running Teams Free edition you can't add external contacts (federation).


I guess you haven't started the migration from Teams Free to Teams with Office 365 subscription yet, correct?

To add to Linus - have the others in the organisation also been set up to use Teams? If it is only you and the admin and you try to add others in your organisation this may be the reason why you are getting the error and why you can only add the admin. 


Best, Chris

@Christopher Hoard 

@Linus Cansby 


  • Version (64 bit). It was last updated on 05/03/2019
  • Migration is yet to begin
  • Other staff in org have accounts and get the same reponse


And you can sign into the web version at the URL that Linus provides above with your work credentials and see the same view as that of the desktop client?

Best, Chris

@Christopher Hoard 


  • Web view is working, same issue
  • Error message on web has replaced 'mate' with 'buddy', presumably geo-specific lingo
best response confirmed by Sim00 (Occasional Contributor)
Hi @Sim00

I can't think of any specific reason why this would not work. Sounds like a bug and I'd probably recommend raising a ticket at this point. Linus, earlier in this string set up a Free account and had no issue - yours is impacting all users so sounds like there is an issue with the tenant itself. You should be able to add internal users to favourites if they are set up correctly and no major changes have been made to the tenant.

I look forward to hearing what the issue was with this. Others in the community may also have a solution based on their experience.

Best, Chris

@Sim00 Where do you select add to favorites? I have the option to tag a contact as favorite in the Chat app in Teams or Add contact in the contacts section in the Calls app.

I am clicking "Chat" tab, "Contacts" sub-tab, "...", "Add contact to this group"

Same issue here, been struggling with this for a while now. We also have an Azure account, seems like there is an issue with the two. 


Most functionality works, but with the free version of Teams we were not suppose to be able to user Planner, but we've been using the heck out of it building all sorts of things. But in a task we can not add Comments currently, either. 


Really hoping this gets fixed soon, we have decent size group of dev/ops users and PMs anxious to put this app to good use. 


MS please jump on these issues.


Similar problem, I can add 365 users to favorites but not free Teams users. Adding external user generates the "We couldn't add a buddy to the group" message.


Same questions as others, has this been resolved?

@ICS-DaveHere is the answer I got back from Microsoft....

MS Response



@Sim00  and MS, 


I am having the same issue when trying to add some internal contacts: "We cannot add a buddy to the group".  We are using O365 E3 licensing and are making the transition from Skype for Business to Skype within Teams. 


We are able to add some internal contacts to the group, but on others we receive the error I mention above.


Have there been a response posted from MS?

Has anyone figured out how to get around this issue?



@Sim00 I'm having this exact same issue. Per one of the responses below it looks like this is a problem with organizations that don't use Exchange Online and instead have an on premise Exchange Server.  Is that your situation in your office as well?

Today marks 6 months. My client last updated 2 days ago. The problem still persists and we are unable to use this basic feature. We still haven't got sign off for our migration to O365.