HID Interface is not a selected device

%3CLINGO-SUB%20id%3D%22lingo-sub-2100008%22%20slang%3D%22en-US%22%3EHID%20Interface%20is%20not%20a%20selected%20device%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2100008%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20connect%20Teams%20to%20use%20my%20composite%20USB%20audio%20device%2C%20the%20log%20file%20says%3A%3C%2FP%3E%3CP%3EhidDevice%3A%20'failed%20to%20resume%20device%20name%3A%26nbsp%3B%20XXX%20HID%20Interface%20(SpeakerPhone%20USB)%3C%2FP%3E%3CP%3EhidDevice%3A%20%5BsetValue%5D%3A%26nbsp%3B%20XXX%20HID%20Interface%20is%20not%20a%20selected%20device%3C%2FP%3E%3CP%3E%5BScenario%5Dhid_device_resume_from_app_to_non_selected_hid_device%20%5Bstep%5D(1)stop%20(1ms%2F1ms)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20see%20my%20HID%20device%20and%20audio%20devices%20in%20Device%20Manager.%20But%20I%20didn't%20see%20my%20audio%20device's%20name%20been%20shown%20under%20Audio%20devices%20list%20on%20Teams%2C%20and%20also%20I%20didn't%20receive%20offhook%20message%20from%20HID%20message.%20Can%20anyone%20give%20some%20advice%20on%20what%20might%20be%20wrong%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2100008%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2100192%22%20slang%3D%22en-US%22%3ERe%3A%20HID%20Interface%20is%20not%20a%20selected%20device%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2100192%22%20slang%3D%22en-US%22%3E%3CP%3EHere%20are%20more%20logs%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EhidDeviceManager%3A%20%5BgetSelectedMicFromManager%5D%3A%20Device%20with%20matching%20label%20XXX%20is%20not%20a%20HID%20device%20or%20is%20not%20in%20the%20HID%20devices%20map%3CBR%20%2F%3EhidService%3A%20HIDControlsV2%20sfbIsRunning%20%3D%20true%20isHidDisabledInSfb%3Dfalse%20isDeviceDisabled%20%3D%20null%20sfbBigSwitchHidSupportEnabled%20%3D%20true%3CBR%20%2F%3EhidDevice%3A%20stopped%20ringing%20for%20device%20name%3A%20XXX%20HID%20Interface%20(SpeakerPhone%20USB)%3CBR%20%2F%3EhidDevice%3A%20%5BsetValue%5D%20for%20device%20name%3A%20XXX%20HID%20Interface%20(SpeakerPhone%20USB)%20%3A%20called%20with%20usagePage%3A%20LEDs%20(8)%2C%20usage%3A%20Ring%20(10)%20isRelative%20(undefined)%2C%20value%3A%200%20Successful%3CBR%20%2F%3EhidDevice%3A%20%5BDevice%20Status%5D%20Device%20Opened%3A%20true%2C%20Device%20Selected%3A%20false%2C%20Driver%20Selected%3A%20false%3CBR%20%2F%3EhidDevice%3A%20%5BbaseDriver%5D%3A%20device%20XXX%20HID%20Interface%20has%20selected%20property%20set%20to%20false%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F943888%22%20target%3D%22_blank%22%3E%40lwlh123%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

When I connect Teams to use my composite USB audio device, the log file says:

hidDevice: 'failed to resume device name:  XXX HID Interface (SpeakerPhone USB)

hidDevice: [setValue]:  XXX HID Interface is not a selected device

[Scenario]hid_device_resume_from_app_to_non_selected_hid_device [step](1)stop (1ms/1ms)

 

I can see my HID device and audio devices in Device Manager. But I didn't see my audio device's name been shown under Audio devices list on Teams, and also I didn't receive offhook message from HID message. Can anyone give some advice on what might be wrong?

 

Thanks!

 

1 Reply

Here are more logs:

 

hidDeviceManager: [getSelectedMicFromManager]: Device with matching label XXX is not a HID device or is not in the HID devices map
hidService: HIDControlsV2 sfbIsRunning = true isHidDisabledInSfb=false isDeviceDisabled = null sfbBigSwitchHidSupportEnabled = true
hidDevice: stopped ringing for device name: XXX HID Interface (SpeakerPhone USB)
hidDevice: [setValue] for device name: XXX HID Interface (SpeakerPhone USB) : called with usagePage: LEDs (8), usage: Ring (10) isRelative (undefined), value: 0 Successful
hidDevice: [Device Status] Device Opened: true, Device Selected: false, Driver Selected: false
hidDevice: [baseDriver]: device XXX HID Interface has selected property set to false

 

 

@lwlh123