Having issues signing into a yealink teams room panel

Copper Contributor

I've read the doco on the android teams devices being logged out, but I don't think that is the issue here.


One of the panels was logged out and when I go and try and log in again via the I get the following message after entering the login details - "Signing out... You're already signed in with another account.  Sign out and try again."


I can see in azure saying it was a successful login, and no failures.


I've tried rebooting and just then a factory reset but I get the same message.  I've also tried logging in via the teams admin portal, the device login page and via the device it self by entering in the username and password directly.  All give the same error message. 


There's no logout button, when the device starts it goes to the "You'll need to sign in to use this app" screen.


Any ideas?

32 Replies
best response confirmed by Acasey80 (Copper Contributor)

@Acasey80 Exact same issues with our devices. The only thing that changed recently was the type of license as the Teams licensing was changing.

Did you find a solution in the end?

@ChrisCurtisIT Oh that's a very interesting question.  We have two rooms side by side, a main room and a smaller one that can be combined.  The main room has a Microsoft Teams Room Standard license, and the one that is having issues has a Microsoft Teams Rooms Basic.


I wonder if they have issues with the basic license.


I'm not getting much help from Yealink, my next step was opening a call with MS to see if they can look into it.

I'm getting a rooms standard license purchased so i can test to see if that fixes it. I'll keep you posted.

@Acasey80 Yeah i'm beginning to think that the other license may be end of life so running into some issues. I did manage to get one device working after a few hours f trial and error but the others do not want to follow suit! 

I have a feeling it may be an InTune license that may be required too.

Yep that was it. I changed from the Teams room basic to a teams room standard and the panel came back to life. So it looks like the basic licenses just don't work. (We don't use intune either, so I don't think that's an issue).

Thanks for pointing me towards the right answer.
I have the same problem and today I switched to Teams Room Standard but it keeps coming with the message: 'Signing out... You're already signed in with another account'.
We have Intune, but I have signed out the account everywhere I could think of
Same exact issue here - except we have a Crestron TSS-1070 scheduler. Have tried everything under the sun - including a different account that was successfully used the day before. Reading about the licensing switch, we had been using TR Standard on an Enterprise Agreement - which means nothing changes for us (for now, anyway - and the rest of our 30+ rooms are fine). As one of our tests, I added a TR Pro license, and switched the account to that. Problem persists. We are perplexed. If anyone comes up with anything else, I'm all ears.
I managed to resolve it.

Firstly, you'll need a standard or Pro license for your Teams room now.

Next in InTune, go into your Devices and then into Android Enrollment. Scroll to the bottom and in the section that says "Android Device Administrator" click the "Personal and Corporate Owned Devices" and tick the box in here to "Use Device Administrator to manage Devices". Sign into your device again and you should be golden!



Even though we have NO Intune configuration for Android devices, so in theory they should not even be attempting to find the company portal....your solution was successful for us, with our 3 Crestron TSS-1070 panels.  THANK YOU!

You were right! Fixed it, thanks!!
Words cannot express how happy I am to see this post. This totally was the fix on my Crestron devices. Microsoft support was continually telling me that I needed to engage Crestron directly to have them tell me how to reset the device (after I had already factory reset it over and over again).

I've been frustrated with this since January and FINALLY someone has some answers. Thank you so much!

Hi all, as of 1 June, do your Room Pannel are working with Teams Room Basic? Mines are not. I have had Android Administrator turned ON for many years, i have Intune, I give Intune licenses to the Room Pannel user ... nothing works. Any other ideas?

@Petrix I'm pretty sure the Basic licenses are now defunct. You may want to look at Teams Room Standard or Pro licenses instead. We used a Teams Shared Devices License on some of ours to cut the costs.

Hi, no, is the other way around see here, Standard is deprecated and they only have Basic - Free one (this work perfectly for a Teams System (system = compute and touch panel, Basic only allows 1 device login, so the Room Panel it would be the 2 login which is not allowed by the license). But my case is that we have 10 small rooms (phone booths) that only have the Room Panel for Free-Busy, is NOT OK to pay 40 euro only for Room Panel's don't you think. I see in the above link that a cheap license for Room Panel will come in the future. Until then we have to pay full price :((, not acceptable.

@ChrisCurtisIT  .. Hello Chris, so this is the exact issue we are having at the moment. We have a Polycom teams conference system that is getting that exact error. We also just had a Polycom CCX500 teams phone do the same thing. We also did not have that Android device Administrator check box mark checked. My question is: we have lots of these sorts of devices running successfully without this issue, do you know if we turn this option On if it will mess up any of these other devices?? thx

@pjamies Hi! We had 1 device that was working with 4 others not (we also have 100+ Teams Phones), when i checked this box, they all started working with no complications or issues anywhere else. So As far as I am aware and from my experience we have had no issues.


My Yealink Room Pannels still not working with the Basic license. They require two times to sign in, which works for about 10 min then they log off the account. :(
I would look at purchasing a Pro license and/or a Teams Shard Devices license in that case.

Worked like a charm for us, several Yealink A20+CTP18 & A30+CTP18 with the same problem after doing firmware upgrades & Teams App updates.

The problem was not Yealink related, it is the Teams App version combined with the Intune Android settings @ChrisCurtisIT mentioned:

Next in InTune, go into your Devices and then into Android Enrollment. Scroll to the bottom and in the section that says "Android Device Administrator" click the "Personal and Corporate Owned Devices" and tick the box in here to "Use Device Administrator to manage Devices". Sign into your device again and you should be golden!

Thanks to ChrisCurtisIT