Guests don't appear in Add member box in Teams

Occasional Contributor

I added guests (gmail address no licence) to Azure directory, authorised access to invitees in several places including Teams admin center or Teams.


Yet when in teams I attempt to add member to a team in teams using the add member button, when I type in the adress my guest dare not proposed.


I added the guest in the team directly in Azur and it worked. Yet in teams my guests don't appear.


Conclusion, my guests cannot access to Teams.

14 Replies
Have you made sure you set guests allowed in groups in the setting and add-ins and also also from teams
When did you turn on the Guest access in your Teams Admin? This usually can take up to 24 hours to take effect.

Thank you for your reply I ve been struggling for weeks with that one.  Here is the main steps I did:

In Sharepoint, Azure, team admin, team

 teams.PNGteam admin.PNGazure.PNGSharepoint.PNG


I couldn't find the add-ins in the office admin

add Ins.PNG

I used the following check list



I gave up for a few weeks and found the check list. Team guest acces was already setup.

I tried again yesterday afternoon I found the check list using azure, team admin, sharepoint. 

I just double checked it still doesn't work (way 24h after this). Again thank you for your replies, you make me hope again




The setting in Teams moved to the new admin center, here ...



I remember I went there as well, but I got the following error:


team admin.PNG

It says data download impossible try again (sorry it's in french)

I tried many times in vain

You are lacking a lot of features in your admin center. Are you on a gov tenant?

I suppose by gov tenant you mean my service provider ? Yes it is a french one. 1and1. Should I revert back to them ?

Gov tenant meaning government tenant. Which is under higher security and usually has less features available such as guest access etc. They just got Teams recently launched to be used.

If it's just a service provider and not a gov tenant then that shouldn't be the case, but you're admin center is definatley behind the times. If you go to your regular admin portal > Services and add-ins > Microsoft Teams. Can you screenshot that, do you have the guest access section there in the drop down and enabled?

Chris, you seem to know you way around...cheers. I posted a screenshot of my regular admin portal, I don't have the add ins optionadd Ins.PNG

Odd, are you global admin? If so and that's all you get then your ISP must limit your setup in some way. You'll end up having to go through them.
I believe I wasn't initially, but I complain when I first attempted to setup my guests...They told me I was the admin they coudn't help. From that day, I suddenly started to access many many ressources. I'll go through them. I'll keep you posted

And above all, thank you to you all !