Getting stuck on "More information required"

New Contributor

Have a free Teams-account (until we get 365 in the office)

Have been working for quite a while without any problems.

This morning I was logged out and tried logging in.

Logged in and get this message:
"More information required
Your organisation needs more information to protect your account"

I click "next" and it just gets stuck there (dots on top of the window moves)

Works fine for other users in the office.

Same result on Windows 10, Android App, Web (Chrome and Egde, also incognito). Also tried on another computer (Desktop+web), same problem.


Any ideas?




7 Replies


@DeanPearcey  if you have recently changed your password this will happen to try to exit MS Teams from trying icon and log in again so it asks for the new password also there is a user voice for this issue that happens to many other users;


here is another workaround besides the one I mentioned above


@Pervaiz Dostiyar 

I am getting the same problem but on Windows 10 app. It works fine on browser. The solutions did not work for me. And I did not change my password recently. After entering the email id and password on prompt, it is asking for "More Information Required, your organisation requires more information to keep your account secured." It is happening since yesterday.


Thank You.



I have the same issue since this weekend.
I have tried many ways but I still cannot get it work.
Here are what I have tried.
- Logout system tray.
- Remove and install MS Team.
- Reset password




I have exactly the same problem ...............any help welcome have tried everything including uninstall and reinstall 






I still can't log in. I think this issue is very serious and requires production hotfix.


I think they have fixed it. I can log in now.


Any solution to the problem yet ? Encountering the same issue