Forwarded Ms teams link. Link works but doesn't give meeting access

Occasional Visitor
Hi all,

I've just got a new laptop and I am having to forward my MS Teams meeting invite links from my work email (not setup yet on my new laptop) to my gmail so I can use MS Teams on my new laptop.

When I click on the meeting link inside of the forwarded email, it opens up my chrome browser and then says "open Ms teams app". All of which is normal and good. It then let's me click on the usual "join" button and then says "the host will let you into the meeting soon". That's where it stays.

So I then contact the person running the meeting and ask them if they are in the meeting, which they are.

They then tell me that on their screen, it shows me as a participant but it says I'm disconnected. I tried deleting the chrome cache, uninstalling teams etc, but nothing worked.

Then the person in the meeting sent me an invite direct to my gmail address on my new laptop and it allowed me in first time.

I can't figure out why it's doing this, but temporarily I need to keep forwarding the work emails via my gmail address.

Anyone have any ideas as to how I can get around this problem please?
1 Reply


Since the community has not yet responded to your post, you might want to seek assistance with other resources that are focused on tech support:


  • Ask your IT manager to open a support case or call Microsoft using the support line you were given.  Other options for business subscription admins are listed here:

Get support | Microsoft Docs