Facebook connector not working

New Contributor

Tried to set up the Facebook connector. When I choose configure it prompts me to login which I do and then it opens Facebook in a browser within Teams and then thats it.

I checked the Business integration settings within Facebook which says the Office 365 is active but if i close the browser within Teams it just leaves me back at the 'To add this connector login to Facebook' but is still not configured.

 

Any suggestions ??

13 Replies

Hi @neilatpeel 

 

It is working for me - may be browser related for you as I am using Edge Canary latest version. But I will walk you through the steps I took to get it to work

 

1. Add a Team to the Connector

 

TeamsFB1.PNG

 

2. Select the channel to push notifications into

 

TeamsFB2.PNG

 

3. You will come to a login page. Login with the credentials of the Facebook user

 

TeamsFB3.PNG

 

4. It will open a browser. Login with the users Facebook credentials

 

TeamsFB5.PNG

 

5. Continue as user

 

TeamsFB6.PNG

 

6. Set connector settings in Facebook

 

TeamsFB7.PNG

 

7. Complete the connector link in Facebook. 

 

TeamsFB8.PNG

 

8. Make sure you have liked pages in Facebook (not follow, sign up etc)

 

TeamsFB9.PNG

 

9. Back in Teams the connector should now be configurable, and the Pages you liked should show

 

tEAMSFB10.PNG

 

10. Save the connector

 

TeamsFB11.PNG

 

11. Confirmation of setup will now be in the Channel

 

TeamsFb12.PNG

 

Let me know how you get on. A few other things I can think of

 

- May have cached credentials in the browser - try it incognito or clear history/credentials

- May not be on the latest version of the Teams client - update this to latest version if possible

 

Hope this answers your question!

 

Best, Chris

Hi Chris,

Thanks for the reply. I did the same as you, I get as far as step 8 but wen I go back to Teams it is not configurable.
I am using the Teams app but I also tried in Chrome. I will remove all and try in Edge to see if this makes any difference and report back.

Neil
Be good to hear from you.

I think you once all the steps up to 8 are done you should be able to go existing connectors on the account and it still be there - but let’s try on Edge Canary first

Best, Chris

@Christopher Hoard 

Similar issue but this is the only active thread I could find on the Facebook Connector.

 

I already had Facebook connected but now when I go in to change the configuration, I get a web connection error. Originally I was trying to add a liked page, but that's when the connection began to break down. First it couldn't find any pages I like but now all I get is a connection error similar to a 404 screen (it's hard to see the entire error message as it doesn't fit in the pop up window).fb error.png

Have you tried removing the connector and linked account and setting it back up again? Just tested and that seemed to work for me - granted that is a workaround.

Best, Chris

@Christopher Hoard 

The error screen appears after clicking the Configure button. Where else could I go to remove the connector?

Next to the channel in the team and select the three dots (...) then connectors. This should bring up the connectors page. Under Manage go to My Accounts and remove the account linked to Facebook, once done, go back to Configured then selecting Facebook should take you back to Step 3 above.

It is definitely working for me - but today I am working off a hotspot direct to the internet. If you are on a corporate network it could be something blocking it like a proxy. Have you tried outside the network or on a different machine?

Hope that helps

Best, Chris
I think we may have found the root issue. In Configured and Managed, the Facebook Connector is not listed but in the All apps I cannot Add, only Configure. Seems like the app thinks it's still connected but actually it's not. I'm working from home so it shouldn't be the firewall.

@Ben Biddle It only show 'Configure' because the app is still installed on the team. If you click the ... then manage team, then select Apps a the end, you can uninstall the app and it will show as 'add' again.

 

Neil

Hi Neil,

Did it work out?

Best, Chris

@Christopher Hoard No using Edge didn't seem to help. I've uninstalled and will attempt to start from scratch with it.

 

Neil

That is looking like the solution at this point - complete the removal from the team and starting it over.

Best, Chris
Hi