Extension dialling on Teams Phone doesn't work on Auto Attendant and won't transfer to the user

Brass Contributor

We are looking to switch to Teams Phone but we need to maintain our 4 digit extensions for the time being.  I'm having a weird issue though where I can never get it to transfer to any user from the auto attendant.


I have tried using Direct Routing, Operator Connect providers, and even Microsoft Calling Plan.  I use PowerShell and add the extension as shown here Auto attendant and call queue dialing and voice recognition reference - Microsoft Teams | Microsoft ... where if the user's number is 4161231234 and extension is 2155 it shows +14161231234;ext=2155 in AzureAD.


What happens though is the auto attendant will say to dial the extension, and it's configured to dial by extension as well, then the user dials 2155 for example, but it will instead go silent for 5 seconds then she goes "If you have finished, press the pound key."  You press # and she says "Sorry, I could not find a similar extension or menu option."  I can enter any 4 digit extension and it says the same thing, as in it doesn't seem to even be checking or trying.


If I change the auto attendant to dial by name, I can speak a name and she transfers the call every time.  It's just when dialling by extension that never works.  


Is there anything else that I could be missing?

9 Replies

Do you have a on-premises Active Directory? Please run the following commands for the user in your tenant and check

Set-ADUser -UserPrincipalName email address removed for privacy reasons -TelePhonenumber "+14083030000;ext=0000"

With Regards,
Satish U
I just have AzureAD nothing is on premise. If I try your command it says Set-AdUser is not recognized. The one I was using was:

Set-CsUser -Identity "email address removed for privacy reasons" -OnPremLineURI tel:"+1xxxx600130;ext=2199"

When using Direct Routing I would issue this one:

Set-CsPhoneNumberAssignment -Identity email address removed for privacy reasons -PhoneNumber "+1xxxx129586;ext=2122" -PhoneNumberType DirectRouting

In AzureAD it shows the extension, I've just never once been able to get an auto attendant to dial it.
best response confirmed by psychobunny83 (Brass Contributor)
I figured this out in case anyone else has this issue. +14083030000;ext=0000 is not the correct format for me at least the Microsoft documentation says put the number ;ext= extension but the correct format to make it work for us was:


I had been trying for weeks using the ;ext= format and it never works. As soon as I used x instead, it immediately worked for all users. I could even set it in AzureAD without using Power Shell.

I'm using Calling Plan and Operator Connect on 2 different tenants and using the format about with x was the only way for us to get either tenant to work.
Hi sorry I have the same problem as you, could you send me a picture of your Microsoft Teams configuration where the extension field comes out, ie where should I put +14083030000x0000, I'm not sure where to put it.

Another question, I would like to know if what you get to mark # can be eliminated, that is, that only the 4 digit extension is marked and nothing else, without the need to mark the # key.

Translated with (free version)

I actually did it via PowerShell, but in Microsoft Admin Centre, it's the "Office Phone" field when you click "Edit Contact Information" on a user.  You can also do it from Azure Active Directory, as it's the "Business phone" field there.

Regarding the # after, I don't think that's possible from what I can tell. If you don't press # it sits there for 10 seconds or so and then says "if you are finished press pound."

@psychobunny83 Hi, another question, do you know how I can set a PIN code to my voicemall?

@psychobunny83  Hello, we are running to this issue , can you please post your powershell command here ? 




4 digit extension works well. Is there a limit of how many digits the extension can be? Within Teams admin center, we can assign up to EIGHT digit extension. I have changed FOUR digit to FIVE digit extension two days ago but still its recognizing the previously assigned FOUR digit extension. A.D. replication is good and I can see the five digit extension within azure ad on the accounts, but still it's not working.