Error with Tenant switching in MS Teams

New Contributor



i have the following scenario:


i have a work account with office365 license on a work tenant and am able to access it via teams app and via web browser.  As i work in a multinational company that has several MS Teams tenants, as part of a test to see if our tenant was setup correctly, i was added to a group on a different tenant. That worked without any issues and i was able to access all data that was given at my disposal.


Then as part of a test the admin of said group removed my email from the member list, which resulted in end of my access, but the tenant name remained in the selection menu both in the app and in the web interface. When i clicked on it, i was switched to their tenant however there were no groups for me to access. We repeated this process one more time (they added me again and after verifying that all worked fine removed me again) just for good measure.


Then i used the permission link ( to remove given permissions to the above mentioned tenant. However, now, the tenant is still visible in the selection menu, but when i try to access it, it returns an error and reroutes me back to my home tenant.


The reason why i even attempted this was because a similar issue occurred with one of the coworkers and no-one seems to be able to fully understand how or why. No in my case it may be because of my tampering with permissions. What i don't understand is, why is this even possible. Is there a way to completely remove any trace of access to a certain tenant? Or reset all permissions given by the user and clear all data collected on the user by the tenant in question? Any advice here would be amazing.

1 Reply


Hello! You've posted your question in the Tech Community Discussion space, which is intended for discussion around the Tech Community website itself, not product questions. I'm moving your question to the Microsoft Teams discussion space - please post Microsoft Teams questions here in the future.