Error when clicking on image in list item (notAcceptable, Accept header cannot be satisfied)

%3CLINGO-SUB%20id%3D%22lingo-sub-2595111%22%20slang%3D%22de-DE%22%3EError%20when%20clicking%20on%20image%20in%20list%20item%20(notAcceptable%2C%20Accept%20header%20cannot%20be%20satisfied)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2595111%22%20slang%3D%22de-DE%22%3E%3CP%3EI%20have%20created%20a%20list%20in%20a%20microsoft%20teams%20channel.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Simon2021185_0-1627570308616.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F299206i1A1A7F143C8CE127%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Simon2021185_0-1627570308616.png%22%20alt%3D%22Simon2021185_0-1627570308616.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20click%20on%20the%20little%20preview%20icon%2C%20I%20get%20the%20following%20error%20message%3A%3C%2FP%3E%3CP%3E%7B%22error%22%3A%7B%22code%22%3A%22notAcceptable%22%2C%22message%22%3A%22Accept%20header%20cannot%20be%20satisfied%20(Accept%3A%20'text%2Fhtml%2C%20application%2Fjson'%2C%20Content-Type%3A%20'image%2Fjpeg')%22%7D%7D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2595111%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EBest%20Practices%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

I have created a list in a microsoft teams channel.

Simon2021185_0-1627570308616.png

 

When I click on the little preview icon, I get the following error message:

{"error":{"code":"notAcceptable","message":"Accept header cannot be satisfied (Accept: 'text/html, application/json', Content-Type: 'image/jpeg')"}}

5 Replies
Hi @Simon2021185

1.) Do you get the same error in the Lists Web Experience?
2.) What about if you convert the image, to say, a png and replace it. Same issue?
3.) To confirm that is an Image column you are using

Let me know

Best, Chris

@Christopher Hoard 

 

1. "Open in sharepoint" and then clicking it in the browser leads to the same error.

2. PNG and also totally different images have the same issue.

3. It is an image column. Per attachement it works.

Hi @Simon2021185

As this is happening in both Teams and the underlying SharePoint site, and it is non-image specific then I would say this is an issue on Microsoft's end with preview.

The solution would be to open up a ticket and specify the information above and how it is occurring in both SharePoint and Teams with different image types.

Hope that answers your question

Best, Chris
Many thanks! How can I open a ticket? Is that something only the admin can do?
Yes, only the admin will be able to do it via the Microsoft 365 Admin Centre > Support > New Service Request :D

Best, Chris