error message: “Something’s wrong with the meeting or the link you’re using to join it”

New Contributor

Hi community members.  I have a longstanding problem: Every time I am invited to join a Teams meeting (from various organisations) I get the same error when I click on the link: "Something’s wrong with the meeting or the link you’re using to join it".  I have uninstalled and reinstalled the Teams app for Mac several times, but it remains the same.  Even when I just open the app, with no meeting link, I get this message.  The only option it gives me in the dialogue box is to sign out, but that link doesn't work so I'm stuck with nowhere to go.  Any ideas?  

Many thanks,


5 Replies

@Marcia164 I have the same issue on my 2015 Macbook Pro. Uninstalled and reinstalled twice now, same issue every time. 

best response confirmed by ThereseSolimeno (Microsoft)

I was having same issue. After I deleted Microsoft Teams app I manually deleted `/Users/{username}/Library/Application Support/Microsoft/Teams` folder. And re-installed application and then I saw login screen. I hope this help for others.

Thank you very much, it worked like a charm. You saved my day, cheers! @muratcorlu 

@muratcorlu Hi, i'm just wondering if you can help me with this issue as others seem to got to the bottom of their problem using this solution. I have a MacBook and I'm not too sure how to solve my problem using the steps you've provided. When I try to access the meeting link it just says ' something's wrong with the meeting or the link you're using to join it ' but I can gain access to it via my mobile app. This meeting is quite important for me and I would much rather be able to access it via my laptop.


Thank you :)