Error code - 2:-1001

Occasional Contributor
D'oh! Something went wrong...
If that doesn't work, try signing out and back in.
Error code - 2:-1001
There's a more permanent way to sign in to Microsoft Teams. If you're having trouble completing the process, talk to your IT admin.
1. What is error code 2:-1001?
2. What is the more permanent way to sign in to Microsoft Teams? I am the IT admin.
10 Replies
Don’t think I’ve ever seen this you have a screenshot? Can’t you log in at all? Is it the desktop client?

@adam deltinger yes this is the desktop client. Multiple people in my company using Macs are having problems. Windows client works fine.


Still nobody able to login using Mac OSX desktop client. Might be Modern Auth problem. Forms authentication is enabled on ADFS.

best response confirmed by Takahiro Masuda (Occasional Contributor)

If anybody else runs into this problem this is how I fixed it.


Please follow the below steps:


Go to Go > Go To Folder > Type in:


~/Library/Application Support/Microsoft


Try deleting the Teams folder there.  This appears to be where all the settings, cookies, caches are stored for that current user.

@Takahiro Masuda 

This worked for me. Thank you

@Takahiro Masuda 
Thank you for sharing the fix, although it only fixes the problem for me only once.

Anytime I restart the app, it returns back again so I have to delete the same folder every time I need to use Teams, is there any permanent solution ?



j’ai le même problème avec Teams sur mon Mac (Catalina version 10.15.7).

J’ai fait la manipulation suggérée, mais cela ne change rien, j’ai toujours le même code d’erreur.

Avez vous d’autres solutions?

merci d’avance



Did anyone fix this. Teams were working for me fine it crashed and now and get the error as above?

@Frankie_rawson FIX

Uninstall Teams from your Mac. Look for an older version here

Instal older version.... Run and Log in with you account. Update to latest version via app without sign off

and your are god to go.

For me this happened when I used different login IDs with Modern Auth, somehow Teams got confused. I cleared system cache and problem was solved with it.