Email Address Not Available

%3CLINGO-SUB%20id%3D%22lingo-sub-529027%22%20slang%3D%22en-US%22%3EEmail%20Address%20Not%20Available%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-529027%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20using%20Flow%20to%20create%20Channels%20from%20a%20Sharepoint%20List%20Item.%3C%2FP%3E%3CP%3EEverything%20works%20fine%20until%20I%20try%20to%20send%20that%20Channel%20an%20email.%3C%2FP%3E%3CP%3EWhen%20I%20do%20my%20Graph%2C%20I%20find%20that%20all%20channels%20that%20I%20create%20in%20the%20Teams%20UI%20have%20emails%20assigned%20and%20Channels%20that%20I%20create%20in%20Flow%20do%20not.%3C%2FP%3E%3CP%3EIs%20this%20the%20right%26nbsp%3B%20place%20to%20post%20such%20a%20question%20of%20WHY%20this%20is%20happening%20and%20WILL%20it%20be%20adjusted%2FFixed%3F%26nbsp%3B%20Is%20this%20a%20common%20problem%3F%3C%2FP%3E%3CP%3ETo%20send%20an%20email%20recently%20created%20Team%2C%20using%20FLOW%20would%20mean%20the%20world%20to%20me!!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-529027%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHow-to%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-532032%22%20slang%3D%22en-US%22%3ERe%3A%20Email%20Address%20Not%20Available%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-532032%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F329270%22%20target%3D%22_blank%22%3E%40BigBeuferd%3C%2FA%3E%26nbsp%3BIt%20is%20definitely%20the%20case%2C%20the%20email%20address%20is%20only%20created%20when%20someone%20presses%20the%20button%20in%20the%20UI.%20You%20can%20then%20read%20it%20from%20the%20%2Fbeta%2F%20api%2C%20but%20can't%20trigger%20it%20to%20be%20created.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftteams.uservoice.com%3C%2FA%3E%20would%20be%20the%20place%20to%20go%20to%20request%20this%20feature%20to%20be%20added.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi.  

I'm using Flow to create Channels from a Sharepoint List Item.

Everything works fine until I try to send that Channel an email.

When I do my Graph, I find that all channels that I create in the Teams UI have emails assigned and Channels that I create in Flow do not.

Is this the right  place to post such a question of WHY this is happening and WILL it be adjusted/Fixed?  Is this a common problem?

To send an email recently created Team, using FLOW would mean the world to me!!

 

Thanks.

 

1 Reply
Highlighted

@BigBeuferd It is definitely the case, the email address is only created when someone presses the button in the UI. You can then read it from the /beta/ api, but can't trigger it to be created.

 

https://microsoftteams.uservoice.com would be the place to go to request this feature to be added.