Domain password reset - Teams repeatedly asks to login

Not applicable

Not sure if you guys are aware of this. But after changing domain passwords, Teams enters an infinite loop stating "Your password was changed, please sign in again".


Click the Sign in button. It does its thing and reloads. Opens. showing all your messages and conversations. And then re-prompts you to sign in again!

14 Replies

I haven't run into this yet, my password changes have been graceful so far, but then again I'm rarely on the domain network. I guess it's just another example of poor token handling, you can try deleting all the Team entries under Credentials manager (all 20 of them!) and also the cache in the app install folder. Better yet, raise this as a support call, so they can properly document/investigate this.

It's easiest to just "Quit" teams by right clicking the notification area icon. Then starting back up usually fixes this issue.

Nope,  that doesn't work.


first, right click only gives the option to copy the image.

Second,  I even killed the process, rebooted and the same occurred.

I even went to window stored credentials and deleted everything.  nothing.


Keeps prompting to sign in again.



Ok I fixed it.  


Delete your Windows credentials (all that have date older than your last password change) under control panel "Control Panel\All Control Panel Items\Credential Manager".   Reboot.

Then log onto teams again.  It should then prompt for your new password.


@Tyrone Martin, I have run into this problem now. However, I'd like to understand what functionality I lose by deleting credentials before the most recent one as suggested by you?

I faced this problem in two clients environments. Generaly it's problem with modern authentication. Can you be more specific - what operation system you have, are you using ADFS? 

This worked for us:


Right click on the Teams icon in the task bar 

Select sign out 

Then the program will reboot and a log in screen is presented 

Thank you. That works for me as well. We are using ADFS 3.0 for authentication. With every AD password change, the Teams app is facing that problem. 

Before, our workaround was to manually delete the Teams entries in the Windows Credential Manager.

As just "Sign-off" as described seems to work, it's a better / easier workaround for us.


However, I hope the general problem will be solved soon :)

@Jody Velasco
That didn't work for me. It wouldn't bring up a prompt asking for a password, it only asked for an email address which started the loop again.


Signing out and putting in a wrong email address fixed it for me. It finally asked for a password and I changed it and got signed in.

@tmorgan1982 The same thing happened to me and I deleted all of my credentials, rebooted & then signed out of teams and when I clicked sign on this time, it took me to the screen to type in my password - Finally!  Hope this helps you too.


Your suggestion ended up being the one that worked for me since I, too, was getting auto-logged in after signing out, with no chance to type a password.  Right clicked, chose Sign Out, when prompted for an email I entered a purposely bad address, then it let me log in successfully.  Thank you.

@Tyrone Martin Hi do you happen to know what to do in my Android device? I have a Pixel 4, I tried deleting cache/data and reinstalling the app, the weird thing is that I can login from Chrome in this device.


Thank you, this fixed my issue with login.

After resetting my password my Teams desktop app wasn't allowing me to enter the new password. But entering a wrong email redirected to the ADFS sign in page. I was able to correct my email there and enter the new password too. This is THE SOLUTION !