SOLVED

'Copy Link' for Folder/Files does not work in Teams

This thread has been locked for new comments by a moderator, if you have a new similar issue then please start a new thread.
Occasional Contributor

When you access a document library using the website/SharePoint tab and click on 'copy Link' the dialog opens up and has a spinning circle constantly, doesn't load.Teams-CopyLink.gif

 

145 Replies
We experience this as well. 2 different users.
One user began experiencing this about a month ago. I gave her the workaround to open the document library in SharePoint then copy the link while we figured out a resolution.
Since then I uninstalled teams, cleared out all of the directories left behind, removed her account from the system, then reinstalled Teams.
She had the issue on version 1.4.00.29469. I updated her to 1.4.00.32771 and the issue persists.
I logged her in on my Teams app and her account works fine, so we know its just the Teams app on her system that has an issue.

I created a policy in our Teams Admin to allow public preview access and added her to that group. Turned on public preview on her Teams app and it logged her out then back in. Teams is still at the same update revision and the issue still exists.
I suspect 1 or more added/installed apps in Microsoft Teams Desktop App.
Does any of you know where/how you can find which apps you have installed?

When I click on the 'apps' icon in the left column bottom icon(next to the help, feedback and settings) of Microsoft Teams Desktop app, I see hundreds of available apps. But I don't see a way to filter on the ones I have installed.

@Henry Edwards Same issue here. I noticed this not working as before a few weeks back. In Teams desktop app, select a source document then select "Copy Link" and all I see is a spinning wheel in a popup dialog. Mitigation steps: "Open in browser" then paste the browser address bar link into my target document/email message.

NBelham_0-1639992251507.png

 

@Henry Edwards

Today, instead of an ever spinning wheel I got served with an actual error when I click on the 'Copy link' in the ribbon of the Microsoft Teams Windows Desktop app on the root folder 'Documents/General'. When I click on 'Copy link' on a sub folder or selected file of 'General' I get served with the SharePoint link. But no Teams link anymore...:sad_but_relieved_face::sad_but_relieved_face:.

Florisz_0-1640074480133.png

Click on 'Show detals' ;

Florisz_1-1640074507046.png

Click on 'Copy' ; 

 

 

 

{"innerError":{},"name":"GraphError","correlationId":"47e30ea0-d0d2-3000-872d-7b0b3139dd1e","isExpected":false,"code":"tooManyResources","extraData":{},"response":{"error":{"code":"notSupported","innerError":{"code":"tooManyResources"},"message":"The request is unprocessable because it uses too many resources"}},"status":422,"serverStack":"","request":{"requestUrl":"https://gs1nederland.sharepoint.com/sites/IT/_api/v2.0/sites/root/items/11a7211d-6bed-49f7-8304-65d5847c8962/driveItem/createLink?ump=1"},"error":{}}

 

 

In text:

{"innerError":{},"name":"GraphError","correlationId":"47e30ea0-d0d2-3000-872d-7b0b3139dd1e","isExpected":false,"code":"tooManyResources","extraData":{},"response":{"error":{"code":"notSupported","innerError":{"code":"tooManyResources"},"message":"The request is unprocessable because it uses too many resources"}},"status":422,"serverStack":"","request":{"requestUrl":"https://gs1nederland.sharepoint.com/sites/IT/_api/v2.0/sites/root/items/11a7211d-6bed-49f7-8304-65d5..."},"error":{}}

 

Screenshot after click on 'Copy link' when a sub folder or selected file in 'General' is selected;

Florisz_0-1640075311134.png

 

For me it's working again.

 

I don't get an error but the links again. Glad it is solved.

 

From an IT point of view it is still weird that I had this issue and colleagues did not.

@Henry Edwards @Florisz for me the problem still exists. After about 60 seconds, the initial dialog grow in size but no detail is displayed. That just remains for more than a couple of minutes.

NBelham_0-1640079645326.png

 

I'm encountering this issue as well on my current workstation in the Teams desktop client. My workstation exhibits the same behavior in your post where it'll sit, continue to try and load the Copy Link dialog, get larger, and continue to load forever. I've attempted to clear both the Teams cache and browser cache.

 

Here are my other observations:

  • Copying a link in SharePoint Online works as expected.
  • Copying a link in the Teams browser client works.
  • From a test VM, I was able to open the Teams desktop client and successfully copy a link.

@Florisz @Henry Edwards Hi all - I can see that the links now work to Sharepoint but does not open the link in Teams itself :cry::cry::cry:. Does anyone know if this is actually possible. I do not particularly want to direct users from Teams to SharePoint, it will just serve to confuse them moving from Teams to Sharepoint and then back again.:facepalm::facepalm::facepalm:

For example when I copy a Channel link, I get a link to Teams e.g. https://teams.microsoft.com/channel/etc.. however when I copy a folder in a channel I get a link to SharePoint e.g. https://awspls.sharepoint.com/etc - I would really appreciate any suggestions on how to overcome this if it even possible.

 

cheers

 

As per the initial reporter, in the Teams desktop this functionality appears to be broken for some.
Surely we cannot be expected to clear out of client cache rubbish which break client side functionality! I tried that some days ago and it still didn't work for me. Annoying!
Not helpful as you did not read my question. I can open in sharepoint but i do not get a link to Teams. The original reporter reported no link at all but thanks
@Paul_IQPC As the original reporter advised, 'Copy Link' for Folder/Files does not work in Teams.
Copy Link functionality in SharePoint works fine. It's the Teams desktop app that appears to be somehow broken.

@Paul_IQPC , the original functionality was that after click on the 'Copy link' you would get a popup with 2 tabs. First for the link within MS Teams and second for link to SharePoint. Although the link for Teams was quite ugly as it was a very long link, it was quite functional to keep everything within Teams.
Than the spinning wheel started some weeks/months ago and now we(I) have half the functionality back with links to SharePoint only and not working on the library root folder(General) and files in that folder.
It is obvious that there is some work going on at Microsoft. But it would have been nice if they shared a little info so we know what to expect.
The only thing I know is that they are working on a more seamless Woking together between Teams and SharePoint;
https://admin.microsoft.com/AdminPortal/home#/MessageCenter/:/messages/MC306666?MCLinkSource=MajorUp...

But this is just an educated guess.

Edit: I just realise this link is behind admin center password.

The message is about;

Pairing naming convention between Teams channels and corresponding SharePoint folders;

 

Just chiming in to say "me too" and hoping to see a fix soon.

@Henry Edwards 

 

Yep, same here. So annoying that there has been no action to fix this. Even here at the bottom of the world  (New Zealand), we've been experiencing this since early November 21.  

 

We NEED a solution Microsoft ....... please?

 

NJM 

Snr Desktop Support Tech

University of Otago

@Paul_IQPC  For me it works in Teams web version and Sharepoint. issue is with Teams desktop app only.

 

My users are using Teams web version to copy link

@Florisz Hi Florisz and thanks for that info - it was really helpful. I notice in the thread somewhere that it was suggested that you can open a link in a browser page but I do not see any command to do this. 

 

In a doc on the web it suggested right clicking on a source doc in teams and I should have an Open command but I only see this 

 

2021-12-22_11-53-45.jpg

 

Is this the same for you or anyone else - I was just asking as I need to know if it is a local policy that this is switched off or is it another thing that is broken in teams :smile:

 

thanks

 

P

@Paul_IQPC See the attached

 
 
 

 

Thanks you. If this is from your teams app I guess this must be a local policy in my company to switch this off as I definitely don't see it in my Teams folders - thanks for the info
I've just had a slightly infuriating back-and-forth with Teams support. The person there has claimed that this is a known issue and they aren't working to fix it specifically. Instead they are rolling out the new experience by end-of-year (possibly first week of January). Not the answer my users would be hoping for, but at least it's an answer of sorts.