Clicking a notification does not takes to the actual message delivered inside bot

%3CLINGO-SUB%20id%3D%22lingo-sub-2741584%22%20slang%3D%22en-US%22%3EClicking%20a%20notification%20does%20not%20takes%20to%20the%20actual%20message%20delivered%20inside%20bot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2741584%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20the%20behavior%20on%20Mac.%20I%20am%20not%20sure%20what%20happens%20on%20Windows.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22AvineshwarTexas_0-1631320405313.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F309701i34F3BEA18708E85A%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22AvineshwarTexas_0-1631320405313.png%22%20alt%3D%22AvineshwarTexas_0-1631320405313.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhenever%20a%20%22message%22%20arrives%20in%20my%20bot%20(an%20internally%20developed%20bot%20using%20MSFT%20Bot%20Framework)%20on%20Teams%2C%20I%20can%20see%20the%20%22Activity%22%20getting%20lit%20up%20communicating%20a%20fact%20that%20there%20is%20%22some%22%20notification.%20Also%2C%20when%20a%20message%20arrives%2C%26nbsp%3B%20I%20try%20to%20click%20on%20it%20on%20the%20top%20right-hand%20side%20(Mac%20default%2C%20I%20guess)%20of%20my%20screen.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20I%20get%20landed%20inside%20%22Activity%22%20and%20not%20the%20bot%2C%20i.e.%20where%20the%20message%20has%20actually%20arrived.%20I%20would%20like%20to%20say%20that%20this%20is%20not%20the%20case%20when%20I%20am%20accessing%20the%20bot%20on%20the%20browser%20(Chrome%20only)%2C%20however%2C%20I%20do%20not%20remember%20on%20top%20of%20my%20head.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%2C%20is%20this%20a%20consciously%20known%20behavior%20(or%2C%20Teams%20issue)%20that%20cannot%20be%20fixed%3F%20Or%2C%20can%20we%20do%20something%20about%20it%20being%20the%20bot%20developers%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2741584%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EBot%20Framework%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

Hi,

 

This is the behavior on Mac. I am not sure what happens on Windows.

 

AvineshwarTexas_0-1631320405313.png

 

Whenever a "message" arrives in my bot (an internally developed bot using MSFT Bot Framework) on Teams, I can see the "Activity" getting lit up communicating a fact that there is "some" notification. Also, when a message arrives,  I try to click on it on the top right-hand side (Mac default, I guess) of my screen.

 

However, I get landed inside "Activity" and not the bot, i.e. where the message has actually arrived. I would like to say that this is not the case when I am accessing the bot on the browser (Chrome only), however, I do not remember on top of my head.

 

So, is this a consciously known behavior (or, Teams issue) that cannot be fixed? Or, can we do something about it being the bot developers?

2 Replies

@AvineshwarTexas Is this experience on Teams built-in (purple) or mac native notifications? You can change notification style (Setting > Notifications > Notification Style) and test if it is same behavior for both?

@Tushar Pathak 

Teams built-in (purple)