Cannot resume/end pstn call that has been placed on hold?

Highlighted
Occasional Contributor

Hi All,

 

A weird issue we've had when doing some testing on a tenant.

 

They have direct routing in place with an Audiocodes vSBC and BT SIP trunks.

 

If we place a call in from a mobile to a user's ddi then place the call on hold in the teams client we cannot then resume or end the call. 

 

If we do this on an IOS teams client however it works.

 

We seem to only have this issue with the PC client. I have also eliminated the network by trying it on my home environment.

 

Anyone had this?


Alex

17 Replies
Highlighted

@Alex_Dunlop - When trying to resume the call or end the call what happens? Does the client not let you perform the action. Are you seeing any behavior in the SBC logs whilst attempting these actions (it should attempt to do a REFER etc.)

Highlighted

@Lee Ford thanks for the response.

 

When trying to resume the call you cant, if you click resume nothing happens and a little popup just shows regarding the audio device.

 

From looking at the SBC log I can see we get many 481 Call Leg/Transaction Does Not Exist messages between the client and MS.

 

However doing the same trace with a mobile client and performing the hold and resume we dont see any 481 messages.

 

I'm going to perform a more detailed trace and see if anything else shows up.

 

Alex

Highlighted

@Lee Ford Here's an example call and syslog from the audiocodes. It seems like when the client places the call on hold its almost as though the original call then ends, (i see a bye message) then when you try to retrieve that call off hold there is a 481 Call/Transaction Doesn't exist message.

Highlighted
So the original call looks to be put on hold to transfer to a 3rd party? I can see the REFER from Teams which is accepted, Teams then sends a "user initiated" BYE message, before the INVITE to the 3rd party arrives. What is strange is the 3rd party call to the SIP provider is where the 481 occurs, not with Teams - which is strange.

Just to confirm, you have added the "Teams REFER" rules in to your SBC IP 2 IP routing rules?
Highlighted
Yep the REFER rule is in place.

What's odd is when you place the call on hold the client seems to briefly flick as if its gone to a new call. Which is maybe where that BYE message is coming from?
Highlighted

Further to this, after much testing and tweaking i've now managed to get a little further. After changing some options in the SIP trunk IP Profile i've now got hold and retrieve working, but i don't get music on hold now.

 

I'm pretty sure this is a SIP trunk issue, i've reached out to the carrier to see if they have any ideas.

 

I've put a screenshot down below of the IP profile tweaks i've made.

 

Alex 

Highlighted

@Alex_Dunlop 

Do you have any updates?

After working with MS for 4 months on this issue the L2  telsl me that they are aware of the issue and it is on the roadmap.  Hard to tell if the tech is providing the truth or BS.

We are definitely frustrated with a Beta product being released to their users and having us debug their software for them.  Have tested a different HPBX Product and will probably migrate by end of month.

Rob

Highlighted

@Gfyrlw 

 

I managed to resolve this issue by working with the SIP carrier, they hadn't approved Teams on their trunks so we had to start from scratch and now have a working config.

 

On our Audiocodes SBC I have the SIP Trunk IP profile set a specific way for hold and retrieve, see attached screenshot.

 

There is still a time delay when resuming a call but this is an MS issue that they are aware of.

 

 

Highlighted
I'm still seeing the odd instance of this happening, from looking at the user voice forum a few people are getting this issue intermittently.
Highlighted
Is there anything for Microsoft pstn calling.

Resume button not working
No direct routing
No sbc
Sfb works fine but in sfb call queue call are not receive on sfb
Highlighted
We see head phone device name while resuming call
Its no working on mobile phone too
Cleared cache
Sfb gives differnt issue.
Any work arround or troubleshooting steps.. Will be helpful
Highlighted
Is there anything for Microsoft pstn calling.

Resume button not working
No direct routing
No sbc
Sfb works fine but in sfb call queue call are not receive on sfb
Highlighted
Is it a conference call or one on one call??
Highlighted
Have we checked the calling policies is there any custom calling policies or any changes to default calling policies??
Highlighted

I have the same problem. When I press resume nothing happens, no message on the SBC.  Call Transfer is working, Consultative Transfer is working. 

Highlighted

@wildflavor  This was resolved  on the next day.  it happen on thurs/friday and was resolved on Monday.  No changes done on teams, it was self resolved and seems there was service interruption for short period of time.

 

Sorry for late reply.  

Highlighted
Hi @Alex_Dunlop and Flavio_Goncalves! I am in the same boat! In another thread, I found could be de Call Parking Policy. Tried, no sucess. The interesting is when I do Consultive Transfer, the call goes normally to "hold" and I can resume It without problem!