Cannot Rename a Private Channel that has been Restored

Copper Contributor

Just finding out if this is a bug.




1. User deleted a Private Channel

2. User Restored the Private Channel

3. When User tries to rename the restored Private Channel they don't get the option to Edit Channel.  


See attached screenshot

6 Replies

@Jim Soper 


In order for the user to have deleted the private channel, and then go ahead and restore it, they would have had to be an owner of the channel.


In doing so, they should also be able to rename the channel through the Edit Channel options.  So if this user was indeed an owner, then something definitely seems weird here.  I've just tested the same experience of deleting and restoring a private channel as an owner, and then renaming, and it worked just fine.


You can rename the channel in the meantime from the Teams Admin Center, but that doesn't explain the mystery of course.

I can't seem to replicate this issue. Tried in 2 tenants. What version are you running? Can you do it from the web client?

Like Adam and Peter, i was also not able to replicate the behaviour in my environment. You can try to rename the channel using powershell like , may be powershell would give you some clue as to why you are not able to rename.

best response confirmed by ThereseSolimeno (Microsoft)

@harveer singh 


I have just replicated the behaviour.  I added a private channel, deleted, restored it and now cannot rename it or remove it.  I can only leave the channel.

And now, 30 minutes later, I am able to edit. Not sure what changed.
I have replicated the same issue, and the options such as "Get link to channel", "Edit this channel" and "Delete this channel". After refreshing the web page the options are restored.